summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2020-07-05 16:34:36 +0200
committerMatt Turner <mattst88@gentoo.org>2020-08-18 20:55:21 -0700
commitcafdf3e090f07d9a3d206af6bdc593db16b1c0a9 (patch)
treed42b8889fa4e638e1decda0b6e8a50091abdbe35 /app-text/asciidoc
parentdev-ruby/rouge: add 3.22.0 (diff)
downloadgentoo-cafdf3e090f07d9a3d206af6bdc593db16b1c0a9.tar.gz
gentoo-cafdf3e090f07d9a3d206af6bdc593db16b1c0a9.tar.bz2
gentoo-cafdf3e090f07d9a3d206af6bdc593db16b1c0a9.zip
app-text/asciidoc-9.0.2: version bump
Bump app-text/asciidoc to version 9.0.2. This series updated to a new top-level Makefile, which the ebuild now makes use of. It also replaces the "examples" USE flag with "doc", since the new Makefile has a corresponding target "docs" that also includes the example website. This commit also adds Python 3.9 to $PYTHON_TARGETS, since the tests pass when run under it. Closes: https://bugs.gentoo.org/732658 Closes: https://github.com/gentoo/gentoo/pull/16934 Signed-off-by: Marc Joliet <marcec@gmx.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest2
-rw-r--r--app-text/asciidoc/asciidoc-9.0.2.ebuild (renamed from app-text/asciidoc/asciidoc-9.0.0_rc2.ebuild)26
2 files changed, 11 insertions, 17 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 93bda0acf7c7..53acfdadb8bb 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,2 +1,2 @@
DIST asciidoc-8.6.10_p20181016.tar.gz 576694 BLAKE2B 4d255606675346d00ab03398bf48cb30d357f9f9366944e4faf66ae4c96dafce49acdd930fc848f3dbb2d704a004bb5815d17b53416a76c8368a92e4716328b2 SHA512 801f360b0c444e932f1c50897d446de0ec3f0fb2206080b5aa6dda396fede96065f7bb629a84c8a8e40c5d8897f305fdb1877512f04ae757f3b142fd3a7305d0
-DIST asciidoc-9.0.0_rc2.tar.gz 1145229 BLAKE2B e820a957a5e03f8b28e94fb0e9514b2beebe5b08a30357b7ab70db326894270972cfee1b44c30d51dc1c4794e91a09e36acbf9e464386d9e932ac7d32e2f8e93 SHA512 61ea1eb74a2e2da76f92e32ef279f8940fa4ea77a82078e15b54c7c6f134e9d177b0425c6eb8a239cfd2dc6a6f85ad5e93883a447a3e0e92850c0898747b5ea3
+DIST asciidoc-9.0.2.tar.gz 1144308 BLAKE2B 5f5deca6b8c15d4b86e2bd6fdb131908eecd862a5fdbbd8418937050d335a25ad012a3b1bc716379f5623db676176fc6da1a09691c2b42a213a6230281626b69 SHA512 ea8f64ce54d2f1aa38eceb3c1c9be17b388776de58038f3b888ac5ebed76337fa2779e43eb7f47174adf0a0446ee808dbd1e4f8f7e1d7db99db7c4c8584d5624
diff --git a/app-text/asciidoc/asciidoc-9.0.0_rc2.ebuild b/app-text/asciidoc/asciidoc-9.0.2.ebuild
index a9c28a003493..51bbc5e7936b 100644
--- a/app-text/asciidoc/asciidoc-9.0.0_rc2.ebuild
+++ b/app-text/asciidoc/asciidoc-9.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit autotools eutils python-single-r1 readme.gentoo-r1
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/${PN}/${PN}-py3/archive/${PV/_/}.tar.gz -> ${P}.tar.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples test"
+IUSE="doc test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -54,6 +54,9 @@ src_prepare() {
sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
asciidoc.py || die
+ # enforce usage of the configured version of Python
+ sed -i -e "s:python3:${EPYTHON}:" Makefile.in || die
+
eautoreconf
}
@@ -61,25 +64,16 @@ src_configure() {
econf --sysconfdir="${EPREFIX}"/usr/share
}
-src_test() {
- local -x ASCIIDOC_PY=asciidoc.py
- "${EPYTHON}" tests/test${PN}.py run || die
-}
-
src_install() {
default
+
+ if use doc; then
+ emake DESTDIR="${D}" docs
+ fi
+
python_fix_shebang "${ED}"/usr/bin/*.py
readme.gentoo_create_doc
-
- # Below results in some files being installed twice in different locations, but they are
- # in the right place, uncompressed, and there won't be any broken links. See bug #483336
- if use examples; then
- # examples/website is full of relative symlinks,
- # deref them for copying, which dodoc doesn't do
- cp -rL examples/website "${ED}"/usr/share/doc/${PF}/examples || die
- docompress -x /usr/share/doc/${PF}/examples
- fi
}
pkg_postinst() {