summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/aspell/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/aspell/files')
-rw-r--r--app-text/aspell/files/aspell-0.60.5-nls.patch13
-rw-r--r--app-text/aspell/files/aspell-0.60.5-solaris.patch27
-rw-r--r--app-text/aspell/files/aspell-0.60.6-darwin-bundles.patch35
3 files changed, 75 insertions, 0 deletions
diff --git a/app-text/aspell/files/aspell-0.60.5-nls.patch b/app-text/aspell/files/aspell-0.60.5-nls.patch
new file mode 100644
index 000000000000..3ea7c7c3f4ec
--- /dev/null
+++ b/app-text/aspell/files/aspell-0.60.5-nls.patch
@@ -0,0 +1,13 @@
+Index: aspell-0.60.5/Makefile.am
+===================================================================
+--- aspell-0.60.5/Makefile.am
++++ aspell-0.60.5/Makefile.am
+@@ -129,7 +129,7 @@ word_list_compress_SOURCES = prog/compre
+
+ aspell_SOURCES = prog/aspell.cpp prog/check_funs.cpp prog/checker_string.cpp
+
+-aspell_LDADD = libaspell.la $(CURSES_LIB)
++aspell_LDADD = libaspell.la $(CURSES_LIB) $(LTLIBINTL)
+
+ prezip_bin_SOURCES = prog/prezip.c
+
diff --git a/app-text/aspell/files/aspell-0.60.5-solaris.patch b/app-text/aspell/files/aspell-0.60.5-solaris.patch
new file mode 100644
index 000000000000..fc1920a4f57a
--- /dev/null
+++ b/app-text/aspell/files/aspell-0.60.5-solaris.patch
@@ -0,0 +1,27 @@
+* grobian@gentoo.org: on Solaris 10 _XOPEN_SOURCE_EXTENDED may not be
+ defined when including wchar.h with g++
+
+--- prog/check_funs.cpp
++++ prog/check_funs.cpp
+@@ -18,10 +18,6 @@
+
+ #include "settings.h"
+
+-#ifdef DEFINE_XOPEN_SOURCE_EXTENDED
+-# define _XOPEN_SOURCE_EXTENDED 1
+-#endif
+-
+ #ifdef CURSES_NON_POSIX
+ #define CURSES_ONLY 1
+ #endif
+@@ -35,6 +31,10 @@
+
+ #include "gettext.h"
+
++#ifdef DEFINE_XOPEN_SOURCE_EXTENDED
++# define _XOPEN_SOURCE_EXTENDED 1
++#endif
++
+ using namespace acommon;
+
+ StackPtr<CheckerString> state;
diff --git a/app-text/aspell/files/aspell-0.60.6-darwin-bundles.patch b/app-text/aspell/files/aspell-0.60.6-darwin-bundles.patch
new file mode 100644
index 000000000000..39178587f685
--- /dev/null
+++ b/app-text/aspell/files/aspell-0.60.6-darwin-bundles.patch
@@ -0,0 +1,35 @@
+grobian@gentoo.org:
+Darwin: fix for finding bundles (libtool modules, no equivalent in ELF)
+This patch is not really upstreamable, bundles can have any name, but
+Apple suggests using .bundle. libtool on Gentoo generates .bundle files
+for modules on Darwin, so we need aspell to actually look for .bundle,
+not .so.
+
+--- lib/new_filter.cpp
++++ lib/new_filter.cpp
+@@ -458,11 +458,23 @@
+ module->file.assign(option_file.str(), slash + 1 - option_file.str());
+ //module->file += "lib";
+ module->file += filter_name;
+- module->file += "-filter.so";
++ module->file += "-filter."
++#ifdef __APPLE_CC__
++ "bundle"
++#else
++ "so"
++#endif
++ ;
+ } else {
+ if (module->file[0] != '/')
+ module->file.insert(0, option_file.str(), slash + 1 - option_file.str());
+- module->file += ".so";
++ module->file += "."
++#ifdef __APPLE_CC__
++ "bundle"
++#else
++ "so"
++#endif
++ ;
+ }
+
+ return module.release();