summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-05 17:36:16 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-05 17:36:16 +0100
commit28feeb4139bfc6d45b8f1353ba167a5757b1c0ea (patch)
tree3ebd91040cdc5c1bc69bcdb1ba08b348b8d05d0d /app-text/aspell
parentsys-apps/hdparm: Bump to version 9.53 (diff)
downloadgentoo-28feeb4139bfc6d45b8f1353ba167a5757b1c0ea.tar.gz
gentoo-28feeb4139bfc6d45b8f1353ba167a5757b1c0ea.tar.bz2
gentoo-28feeb4139bfc6d45b8f1353ba167a5757b1c0ea.zip
app-text/aspell: Remove linguas_* flags from IUSE.
Bug: https://bugs.gentoo.org/586780 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/aspell-0.60.6.1-r3.ebuild12
-rw-r--r--app-text/aspell/aspell-0.60.6.1-r4.ebuild12
-rw-r--r--app-text/aspell/aspell-0.60.7_rc1.ebuild12
3 files changed, 15 insertions, 21 deletions
diff --git a/app-text/aspell/aspell-0.60.6.1-r3.ebuild b/app-text/aspell/aspell-0.60.6.1-r3.ebuild
index 7c6d6d12527d..6ff3332b5a15 100644
--- a/app-text/aspell/aspell-0.60.6.1-r3.ebuild
+++ b/app-text/aspell/aspell-0.60.6.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,18 +15,16 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~a
IUSE="nls"
PDEPEND="app-dicts/aspell-en"
-LANGS="af be bg br ca cs cy da de de@1901 el en eo es et fi fo fr ga gl he hr
+LANGS="af be bg br ca cs cy da de de-1901 el en eo es et fi fo fr ga gl he hr
hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi"
for lang in ${LANGS}; do
- IUSE+=" l10n_${lang/@/-}"
- # Need to keep linguas_* for now, since aspell uses gettext
- IUSE+=" linguas_${lang/-/_}"
+ IUSE+=" l10n_${lang}"
case ${lang} in
- de@1901) dict="de-alt" ;;
+ de-1901) dict="de-alt" ;;
pt-BR) dict="pt-br" ;;
*) dict="${lang}" ;;
esac
- PDEPEND+=" l10n_${lang/@/-}? ( app-dicts/aspell-${dict} )"
+ PDEPEND+=" l10n_${lang}? ( app-dicts/aspell-${dict} )"
done
unset dict lang LANGS
diff --git a/app-text/aspell/aspell-0.60.6.1-r4.ebuild b/app-text/aspell/aspell-0.60.6.1-r4.ebuild
index fe7d97be8848..33b4d10f3ece 100644
--- a/app-text/aspell/aspell-0.60.6.1-r4.ebuild
+++ b/app-text/aspell/aspell-0.60.6.1-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,18 +15,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE="nls unicode"
PDEPEND="app-dicts/aspell-en"
-LANGS="af be bg br ca cs cy da de de@1901 el en eo es et fi fo fr ga gl he hr
+LANGS="af be bg br ca cs cy da de de-1901 el en eo es et fi fo fr ga gl he hr
hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi"
for lang in ${LANGS}; do
- IUSE+=" l10n_${lang/@/-}"
- # Need to keep linguas_* for now, since aspell uses gettext
- IUSE+=" linguas_${lang/-/_}"
+ IUSE+=" l10n_${lang}"
case ${lang} in
- de@1901) dict="de-alt" ;;
+ de-1901) dict="de-alt" ;;
pt-BR) dict="pt-br" ;;
*) dict="${lang}" ;;
esac
- PDEPEND+=" l10n_${lang/@/-}? ( app-dicts/aspell-${dict} )"
+ PDEPEND+=" l10n_${lang}? ( app-dicts/aspell-${dict} )"
done
unset dict lang LANGS
diff --git a/app-text/aspell/aspell-0.60.7_rc1.ebuild b/app-text/aspell/aspell-0.60.7_rc1.ebuild
index 0ca6438519d2..ffbf2fe55a21 100644
--- a/app-text/aspell/aspell-0.60.7_rc1.ebuild
+++ b/app-text/aspell/aspell-0.60.7_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,18 +21,16 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sp
IUSE="nls unicode"
PDEPEND="app-dicts/aspell-en"
-LANGS="af be bg br ca cs cy da de de@1901 el en eo es et fi fo fr ga gl he hr
+LANGS="af be bg br ca cs cy da de de-1901 el en eo es et fi fo fr ga gl he hr
hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi"
for lang in ${LANGS}; do
- IUSE+=" l10n_${lang/@/-}"
- # Need to keep linguas_* for now, since aspell uses gettext
- IUSE+=" linguas_${lang/-/_}"
+ IUSE+=" l10n_${lang}"
case ${lang} in
- de@1901) dict="de-alt" ;;
+ de-1901) dict="de-alt" ;;
pt-BR) dict="pt-br" ;;
*) dict="${lang}" ;;
esac
- PDEPEND+=" l10n_${lang/@/-}? ( app-dicts/aspell-${dict} )"
+ PDEPEND+=" l10n_${lang}? ( app-dicts/aspell-${dict} )"
done
unset dict lang LANGS