summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 04:21:32 +0100
committerSam James <sam@gentoo.org>2021-08-11 04:36:39 +0100
commit201afe2bae97330580f3cc56c600ab7d0956fa29 (patch)
treefb55317c295043ac1323d331b9100f04db0fda45 /app-text/blogc/blogc-9999.ebuild
parentkde-apps/kde-apps-meta: Stabilize 21.04.3 arm64, #805065 (diff)
downloadgentoo-201afe2bae97330580f3cc56c600ab7d0956fa29.tar.gz
gentoo-201afe2bae97330580f3cc56c600ab7d0956fa29.tar.bz2
gentoo-201afe2bae97330580f3cc56c600ab7d0956fa29.zip
app-text/blogc: add 0.20.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/blogc/blogc-9999.ebuild')
-rw-r--r--app-text/blogc/blogc-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
index 3b3a78e46d44..75b899156927 100644
--- a/app-text/blogc/blogc-9999.ebuild
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/blogc/blogc.git"
inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
fi
-DESCRIPTION="A blog compiler"
-HOMEPAGE="https://blogc.rgm.io/"
-
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- DEPEND="app-text/ronn"
+ BDEPEND="app-text/ronn"
else
KEYWORDS="~amd64 ~x86"
fi
@@ -25,12 +24,12 @@ IUSE="git httpd make test"
RESTRICT="!test? ( test )"
RDEPEND="git? ( dev-vcs/git )"
-
-DEPEND="${DEPEND}
- virtual/pkgconfig
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
test? (
git? ( dev-vcs/git )
- dev-util/cmocka )"
+ )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -40,11 +39,13 @@ src_prepare() {
src_configure() {
local myconf=""
+
if [[ ${PV} = *9999* ]]; then
myconf+="--enable-ronn"
else
myconf+="--disable-ronn"
fi
+
econf \
$(use_enable test tests) \
$(use_enable git git-receiver) \