summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-02-29 01:28:55 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2016-02-29 01:28:55 +0100
commit3c1bc083d6a342a5577021343d63f8f1d3772be7 (patch)
treef89b12b08efa5c398d9cbf6c4bc7682768237eda /app-text/blogc
parentdev-libs/squareball: first release. updated live ebuild (diff)
downloadgentoo-3c1bc083d6a342a5577021343d63f8f1d3772be7.tar.gz
gentoo-3c1bc083d6a342a5577021343d63f8f1d3772be7.tar.bz2
gentoo-3c1bc083d6a342a5577021343d63f8f1d3772be7.zip
app-text/blogc: updated live ebuild
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/blogc')
-rw-r--r--app-text/blogc/blogc-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
index f50ce2b99c03..cddb4f58911f 100644
--- a/app-text/blogc/blogc-9999.ebuild
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="
@@ -11,8 +11,6 @@ if [[ ${PV} = *9999* ]]; then
inherit git-r3 autotools
fi
-inherit eutils
-
DESCRIPTION="A blog compiler"
HOMEPAGE="http://blogc.org/"
@@ -21,24 +19,26 @@ KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
- DEPEND="app-text/ronn"
+ RDEPEND="=dev-libs/squareball-9999"
+ DEPEND="${RDEPEND}
+ app-text/ronn"
+else
+ RDEPEND=">=dev-libs/squareball-0.1"
+ DEPEND="${RDEPEND}"
fi
LICENSE="BSD"
SLOT="0"
IUSE="test"
-RDEPEND=""
-
-# pkg-config is used only to find cmocka libraries
DEPEND="${DEPEND}
+ virtual/pkgconfig
test? (
- virtual/pkgconfig
dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
- epatch_user
+ eapply_user
default
}
@@ -52,5 +52,6 @@ src_configure() {
econf \
$(use_enable test tests) \
--disable-valgrind \
+ --with-squareball=system \
${myconf}
}