summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-08-01 14:48:22 +0300
committerMichał Górny <mgorny@gentoo.org>2018-08-12 19:23:03 +0200
commit8f946421adaff711b86fdd2b68cbcd85cfe4b7e5 (patch)
tree57bb2174efc0fe115c3225a67ca89cb7af4de23d /app-text/capyt/capyt-1.1.1.ebuild
parentsys-libs/librtas: Version bump (diff)
downloadgentoo-8f946421adaff711b86fdd2b68cbcd85cfe4b7e5.tar.gz
gentoo-8f946421adaff711b86fdd2b68cbcd85cfe4b7e5.tar.bz2
gentoo-8f946421adaff711b86fdd2b68cbcd85cfe4b7e5.zip
app-text/capyt: bump to 1.1.1
- Switched to distutils-r1 since Capyt now uses setup.py, - Bumped EAPI to 7, - Updated HOMEPAGE, - Removed empty IUSE, - Updated PYTHON_COMPAT. Package-Manager: Portage[mgorny]-2.3.43.3
Diffstat (limited to 'app-text/capyt/capyt-1.1.1.ebuild')
-rw-r--r--app-text/capyt/capyt-1.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/capyt/capyt-1.1.1.ebuild b/app-text/capyt/capyt-1.1.1.ebuild
new file mode 100644
index 000000000000..3ecc5167169f
--- /dev/null
+++ b/app-text/capyt/capyt-1.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+MY_PV=$(ver_rs 2 '-')
+
+DESCRIPTION="A python3 CLI utility to interface with cpy.pt paste service"
+HOMEPAGE="https://github.com/lbatalha/capyt
+ https://pypi.org/project/capyt/"
+SRC_URI="https://github.com/lbatalha/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"