summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cmigemo/cmigemo-1.3c-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cmigemo/cmigemo-1.3c-r1.ebuild')
-rw-r--r--app-text/cmigemo/cmigemo-1.3c-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-text/cmigemo/cmigemo-1.3c-r1.ebuild b/app-text/cmigemo/cmigemo-1.3c-r1.ebuild
new file mode 100644
index 000000000000..2e1675f42a8c
--- /dev/null
+++ b/app-text/cmigemo/cmigemo-1.3c-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_P="${P}-MIT"
+DESCRIPTION="C/Migemo -- Migemo library implementation in C"
+HOMEPAGE="http://www.kaoriya.net/#CMIGEMO"
+SRC_URI="http://www.kaoriya.net/dist/var/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~ppc x86"
+IUSE="emacs unicode vim-syntax"
+
+DEPEND="dev-lang/perl
+ >=app-dicts/migemo-dict-200812[unicode=]
+ app-i18n/qkc"
+RDEPEND=">=app-dicts/migemo-dict-200812[unicode=]
+ emacs? ( >=app-text/migemo-0.40-r1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2-migemo-dict.diff"
+ touch dict/SKK-JISYO.L
+ if use unicode ; then
+ sed -i -e "/gcc:/s/euc-jp/utf-8/" dict/dict.mak || die
+ fi
+
+ # Bug #246953
+ sed -i -e "s:-Wl,-rpath[^ ]*::" compile/Make_gcc.mak || die
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" gcc || die
+}
+
+src_install() {
+ # parallel make install borks
+ emake -j1 \
+ prefix="${D}/usr" \
+ libdir="${D}/usr/$(get_libdir)" \
+ gcc-install || die
+
+ local encoding
+ if use unicode ; then
+ encoding="utf-8"
+ else
+ encoding="euc-jp"
+ fi
+
+ mv "${D}/usr/share/migemo/${encoding}/"*.dat "${D}/usr/share/migemo/"
+ rm -rf "${D}/usr/share/migemo/"{cp932,euc-jp,utf-8}
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins tools/migemo.vim
+ fi
+
+ dodoc doc/{README_j,TODO_j,vimigemo}.txt
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elog
+ elog "Please add to your ~/.emacs"
+ elog " (setq migemo-command \"cmigemo\")"
+ elog " (setq migemo-options '(\"-q\" \"--emacs\" \"-i\" \"\\\\a\"))"
+ elog " (setq migemo-dictionary \"/usr/share/migemo/migemo-dict\")"
+ elog " (setq migemo-user-dictionary nil)"
+ elog " (setq migemo-regex-dictionary nil)"
+ elog "to use cmigemo instead of migemo under emacs."
+ elog
+ fi
+}