summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/convertlit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/convertlit')
-rw-r--r--app-text/convertlit/Manifest1
-rw-r--r--app-text/convertlit/convertlit-1.8-r1.ebuild47
-rw-r--r--app-text/convertlit/files/convertlit-1.8-respectflags.patch28
-rw-r--r--app-text/convertlit/metadata.xml12
4 files changed, 88 insertions, 0 deletions
diff --git a/app-text/convertlit/Manifest b/app-text/convertlit/Manifest
new file mode 100644
index 000000000000..5b60cae9e384
--- /dev/null
+++ b/app-text/convertlit/Manifest
@@ -0,0 +1 @@
+DIST clit18src.zip 135120 SHA256 d70a85f5b945104340d56f48ec17bcf544e3bb3c35b1b3d58d230be699e557ba SHA512 0d4b7d525f5164a73a47a00e1c4e93ff50e738a4e6c541ded283c4779e6a67138f601c23a41344517ca5d7f8c9141b25cc6edc7f3967fbf9042e99f647354f36 WHIRLPOOL f6cc678fdb4c9b00a5389aa3a2950509c62e5eaf3a9fd14ef38134ae594a583c0d32b0bcd0a940fdc7c5976f0fa160f0fcfb4ae33c5d6251272fc164eee118cb
diff --git a/app-text/convertlit/convertlit-1.8-r1.ebuild b/app-text/convertlit/convertlit-1.8-r1.ebuild
new file mode 100644
index 000000000000..411a44389d52
--- /dev/null
+++ b/app-text/convertlit/convertlit-1.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_P="clit${PV//./}"
+
+DESCRIPTION="CLit converts MS ebook .lit files to .opf (xml+html+png+jpg)"
+HOMEPAGE="http://www.convertlit.com/"
+SRC_URI="http://www.convertlit.com/${MY_P}src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ppc ppc64 x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=">=dev-libs/libtommath-0.36-r1"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+RDEPEND="${RDEPEND}
+ !app-text/open_c-lit"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-respectflags.patch"
+}
+
+src_compile() {
+ tc-export CC
+
+ cd "${S}"/lib
+ emake || die "make lib failed"
+ cd "${S}"/${MY_P}
+ emake || die "make ${MY_P} failed"
+}
+
+src_install() {
+ dobin ${MY_P}/clit || die
+ dodoc README
+}
diff --git a/app-text/convertlit/files/convertlit-1.8-respectflags.patch b/app-text/convertlit/files/convertlit-1.8-respectflags.patch
new file mode 100644
index 000000000000..06209ef62ada
--- /dev/null
+++ b/app-text/convertlit/files/convertlit-1.8-respectflags.patch
@@ -0,0 +1,28 @@
+Index: clit18/Makefile
+===================================================================
+--- clit18/Makefile.orig
++++ clit18/Makefile
+@@ -1,9 +1,9 @@
+ all: clit
+
+-CFLAGS=-funsigned-char -Wall -O2 -I ../libtommath-0.30/ -I ../lib -I ../lib/des -I .
++CFLAGS+=-funsigned-char -I ../lib -I ../lib/des -I .
+ clean:
+ rm -f *.o clit
+
+ clit: clit.o hexdump.o drm5.o explode.o transmute.o display.o utils.o manifest.o ../lib/openclit.a
+- gcc -o clit $^ ../libtommath-0.30/libtommath.a
++ $(CC) $(LDFLAGS) -o clit $^ -ltommath
+
+Index: lib/Makefile
+===================================================================
+--- lib/Makefile.orig
++++ lib/Makefile
+@@ -1,6 +1,6 @@
+ all: openclit.a
+
+-CFLAGS=-O3 -Wall -Ides -Isha -Inewlzx -I.
++CFLAGS+=-Ides -Isha -Inewlzx -I.
+ clean:
+ rm -f *.o openclit.a des/*.o lzx/*.o sha/*.o
+
diff --git a/app-text/convertlit/metadata.xml b/app-text/convertlit/metadata.xml
new file mode 100644
index 000000000000..47df9aaac54a
--- /dev/null
+++ b/app-text/convertlit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription lang="en">
+ Convert Lit is a simple program to use .lit or Microsoft ebook files on
+ Linux. It's able to "explode" the ebook into Open Ebook Specification
+ Format (OEBPS), which than can be read by Opera and other Linux programs
+ (it's just xml, html, png and jpeg). Note that you won't get any
+ DRM-bypassing, so your .lit-file must not be copy protected.
+ </longdescription>
+</pkgmetadata>