summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cook')
-rw-r--r--app-text/cook/Manifest1
-rw-r--r--app-text/cook/cook-1.0.2-r1.ebuild44
-rw-r--r--app-text/cook/metadata.xml10
3 files changed, 55 insertions, 0 deletions
diff --git a/app-text/cook/Manifest b/app-text/cook/Manifest
new file mode 100644
index 000000000000..cb40f182e7cc
--- /dev/null
+++ b/app-text/cook/Manifest
@@ -0,0 +1 @@
+DIST cook-1.0.2.tar.gz 139428 SHA256 b56bab9d5227a37c50e94afc65923a579a0c2ef08a23a6fddb611cb4fd1006da SHA512 6941d3541a6cccc18fcbf14128e0593556148d40f74715b0da943455a223099406d632466137fabef27a2083b582701df92666a1ad6e6a04f5d2d3dc0b62e1a1 WHIRLPOOL b16482bfd614247fda8def080fd872945c614ba13f59471ae84f8e9c4997828630b44b2f4e7d87d586e3ba3d4be41721d8906fa9d8d75c879f84079dd6138bcd
diff --git a/app-text/cook/cook-1.0.2-r1.ebuild b/app-text/cook/cook-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..fa0ccacdc1d7
--- /dev/null
+++ b/app-text/cook/cook-1.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Embedded language which can be used as a macro preprocessor and for similar text processing"
+HOMEPAGE="http://cook.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cook/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ use prefix || EPREFIX=
+
+ dodoc README doc/cook.txt doc/cook.html || die "dodoc failed"
+
+ insinto /usr/share/doc/${PF}/example
+ doins test/pcb.dbdef test/pcb.dg test/pcbprol.ps test/tempsens.pcb || die "doins failed"
+
+ newbin src/cook cookproc || die "newbin failed"
+
+ cat > "${T}"/README.Gentoo <<EOF
+NOTICE:
+
+ ${EPREFIX}/usr/bin/cook has been renamed to ${EPREFIX}/usr/bin/cookproc in Gentoo
+
+ -- Karl Trygve Kalleberg <karltk@gentoo.org>
+EOF
+ dodoc "${T}"/README.Gentoo || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn "${EPREFIX}/usr/bin/cook has been renamed to ${EPREFIX}/usr/bin/cookproc"
+}
diff --git a/app-text/cook/metadata.xml b/app-text/cook/metadata.xml
new file mode 100644
index 000000000000..7f98a9b50485
--- /dev/null
+++ b/app-text/cook/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cook</remote-id>
+ </upstream>
+</pkgmetadata>