summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-25 02:47:43 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-25 02:50:21 -0600
commit829fc2ec07dfac20f79b5f4845484424b66b225b (patch)
treebd13bad3e8dd1809dd0c8a731cef61b4fea0be68 /app-text/csvfix
parentnet-im/telegram-desktop-bin: drop old (diff)
downloadgentoo-829fc2ec07dfac20f79b5f4845484424b66b225b.tar.gz
gentoo-829fc2ec07dfac20f79b5f4845484424b66b225b.tar.bz2
gentoo-829fc2ec07dfac20f79b5f4845484424b66b225b.zip
app-text/csvfix: inherit missing eutils eclass and fix tests
Closes: https://bugs.gentoo.org/630640 Closes: https://bugs.gentoo.org/647986 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-text/csvfix')
-rw-r--r--app-text/csvfix/csvfix-1.6.ebuild5
-rw-r--r--app-text/csvfix/files/csvfix-1.6-shuffle-test.patch20
2 files changed, 23 insertions, 2 deletions
diff --git a/app-text/csvfix/csvfix-1.6.ebuild b/app-text/csvfix/csvfix-1.6.ebuild
index e79e239ef7de..8f35d4536767 100644
--- a/app-text/csvfix/csvfix-1.6.ebuild
+++ b/app-text/csvfix/csvfix-1.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs versionator vcs-snapshot
+inherit toolchain-funcs versionator vcs-snapshot eutils
MY_PV="$(delete_all_version_separators)"
DESCRIPTION="A stream editor for manipulating CSV files"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${PN}-1.10a-tests.patch
+ "${FILESDIR}"/${P}-shuffle-test.patch
)
src_prepare() {
diff --git a/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch b/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch
new file mode 100644
index 000000000000..3916e92e0592
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch
@@ -0,0 +1,20 @@
+Fix the expected data output for the shuffle test.
+
+--- a/csvfix/tests/correct/shuffle.test
++++ b/csvfix/tests/correct/shuffle.test
+@@ -5,10 +5,10 @@
+ "Oscar","Wilde","M"
+ "Charles","Dickens","M"
+ "George","Elliot","F"
+-"Charles","Dickens","M"
+-"Austen","F","Jane"
++"Charles","M","Dickens"
++"Jane","F","Austen"
+ "Herman","M","Melville"
+ "M","Flann","O'Brien"
+-"Elliot","George","F"
+-"Virginia","Woolf","F"
+-"M","Wilde","Oscar"
++"George","F","Elliot"
++"Woolf","F","Virginia"
++"Wilde","M","Oscar"