summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cuneiform/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cuneiform/files')
-rw-r--r--app-text/cuneiform/files/c-assert.diff83
-rw-r--r--app-text/cuneiform/files/cuneiform.1166
-rw-r--r--app-text/cuneiform/files/graphicsmagick.diff43
-rw-r--r--app-text/cuneiform/files/libm.diff25
4 files changed, 317 insertions, 0 deletions
diff --git a/app-text/cuneiform/files/c-assert.diff b/app-text/cuneiform/files/c-assert.diff
new file mode 100644
index 000000000000..0abf1b117343
--- /dev/null
+++ b/app-text/cuneiform/files/c-assert.diff
@@ -0,0 +1,83 @@
+Description: Use the standard C assert() macro, rather than custom Cuneiform
+ one.
+Author: Jakub Wilk <jwilk@debian.org>
+Forwarded: no
+Last-Update: 2011-04-30
+
+--- a/cuneiform_src/Kern/lns32/src/myassert.h
++++ b/cuneiform_src/Kern/lns32/src/myassert.h
+@@ -60,6 +60,8 @@
+ BC++, v3.1 was used as base
+ */
+
++#include <assert.h>
++
+ #ifdef __MYASSERT_H
+ # Error: Do not specify MYASSERT.H directly - use SLANG.H. Postnikov.
+ #else
+@@ -73,45 +75,3 @@
+ #else
+ # define WRONG() (assert(0),FALSE)
+ #endif
+-
+-#ifdef __cplusplus
+-extern "C" {
+-#endif
+-
+-#ifndef MY_DEBUG_LEVEL
+- void __assertfail( char *__msg,
+- char *__cond,
+- char *__file,
+- int __line);
+-#else
+- void my_assert_fail(const char *cond, const char *__file, int __line);
+-#endif
+-
+-
+-#ifdef __cplusplus
+-}
+-#endif
+-
+-#undef assert
+-
+-#ifdef NDEBUG
+-# define assert(p) ((void)0)
+-#else
+-# ifdef _Windows
+-# define _ENDL
+-# else
+-# define _ENDL "\n"
+-# endif
+- #ifdef MY_DEBUG_LEVEL
+- # define assert(p) \
+- ((p)) ? \
+- (void)0 : \
+- (void) my_assert_fail( #p, __FILE__, __LINE__)
+- #else
+- # define assert(p) \
+- ((p) ? \
+- (void)0 : \
+- (void) __assertfail( "Assertion failed: %s, file %s, line %d" _ENDL, \
+- #p, __FILE__, __LINE__ ) )
+- #endif
+-#endif
+--- a/cuneiform_src/Kern/std/CMakeLists.txt
++++ b/cuneiform_src/Kern/std/CMakeLists.txt
+@@ -3,7 +3,6 @@
+ add_library(std32 ${LIBTYPE}
+ src/std.cpp
+ #src/Std.rc
+-src/stdassrt.cpp
+ src/stdbits.cpp
+ src/stdconsl.cpp
+ src/stderror.cpp
+--- a/cuneiform_src/Kern/lns32/CMakeLists.txt
++++ b/cuneiform_src/Kern/lns32/CMakeLists.txt
+@@ -14,7 +14,6 @@
+ src/lns.cpp
+ src/lnscheck.cpp
+ src/lnsini.cpp
+-src/myassert.cpp
+ src/procline.cpp
+ src/puanso.cpp
+ src/rbambuk.cpp
diff --git a/app-text/cuneiform/files/cuneiform.1 b/app-text/cuneiform/files/cuneiform.1
new file mode 100644
index 000000000000..93fd25030a80
--- /dev/null
+++ b/app-text/cuneiform/files/cuneiform.1
@@ -0,0 +1,166 @@
+.TH CUNEIFORM 1 "2010-09-14" "1.0.0" "multi-language OCR system"
+
+.SH NAME
+cuneiform \- multi-language OCR system
+
+.SH SYNOPSIS
+\fBcuneiform\fR [\-\-dotmatrix] [\-\-fax] [\-\-singlecolumn] [\-f \fIformat\fR] [\-l \fIlanguage\fR] [\-o \fIoutput\fR] \fIinput\fR
+
+.SH DESCRIPTION
+Cuneiform is an OCR system. In addition to text recognition it also does layout analysis and text format recognition. Cuneiform supports several languages.
+
+.SH OPTIONS
+.IP "\fB\-\-dotmatrix\fR" 4
+Use recognition mode optimized for text printed with a dot matrix printer.
+.IP "\fB\-\-fax\fR" 4
+Use recognition mode optimized for text that has been faxed.
+.IP "\fB\-\-singlecolumn\fR" 4
+Disable page layout analysis and assumes that the image consists of only one column of text.
+.IP "\fB\-f\fR \fIformat\fR" 4
+Select output format. The following formats are available:
+\fBhtml\fR (HTML format),
+\fBhocr\fR (hOCR HTML format),
+\fBnative\fR (native Cuneiform 2000),
+\fBrtf\fR (RTF format),
+\fBsmarttext\fR (plain text with TeX paragraphs),
+\fBtext\fR (plain text).
+The default is plain text.
+.IP "\fB\-l\fR \fIlanguage\fR" 4
+By default Cuneiform recognizes English text. To change the language use the command line switch \fB\-l\fR followed by a language code (typically an ISO 639-2 three-letter code). The following languages are supported:
+.TS
+ll.
+T{
+\fBbul\fR
+T} T{
+Bulgarian
+T}
+T{
+\fBcze\fR
+T} T{
+Czech
+T}
+T{
+\fBdan\fR
+T} T{
+Danish
+T}
+T{
+\fBdut\fR
+T} T{
+Dutch
+T}
+T{
+\fBeng\fR
+T} T{
+English
+T}
+T{
+\fBest\fR
+T} T{
+Estonian
+T}
+T{
+\fBfra\fR
+T} T{
+French
+T}
+T{
+\fBger\fR
+T} T{
+German
+T}
+T{
+\fBhrv\fR
+T} T{
+Croatian
+T}
+T{
+\fBhun\fR
+T} T{
+Hungarian
+T}
+T{
+\fBita\fR
+T} T{
+Italian
+T}
+T{
+\fBlav\fR
+T} T{
+Latvian
+T}
+T{
+\fBlit\fR
+T} T{
+Lithuanian
+T}
+T{
+\fBpol\fR
+T} T{
+Polish
+T}
+T{
+\fBpor\fR
+T} T{
+Portugese
+T}
+T{
+\fBrum\fR
+T} T{
+Romanian
+T}
+T{
+\fBrus\fR
+T} T{
+Russian
+T}
+T{
+\fBruseng\fR
+T} T{
+mixed Russian/English
+T}
+T{
+\fBslv\fR
+T} T{
+Slovenian
+T}
+T{
+\fBspa\fR
+T} T{
+Spanish
+T}
+T{
+\fBsrp\fR
+T} T{
+Serbian
+T}
+T{
+\fBswe\fR
+T} T{
+Swedish
+T}
+T{
+\fBtur\fR
+T} T{
+Turkish
+T}
+T{
+\fBukr\fR
+T} T{
+Ukrainian
+T}
+.TE
+.
+.IP "\fB\-o\fR \fIoutput\fR" 4
+If you do not define an output file with the \fB\-o\fR switch, Cuneiform writes the result to a file \[oq]cuneiform-out.\fIformat\fR\[cq]. The file extension depends on your output format.
+
+.SH INPUT FORMAT
+Cuneiform can process any single-page image that GraphicsMagick knows how to open. Please consult the \fBgm\fR(1) manual page for the comprehensive list of supported image formats.
+
+.SH HOMEPAGE
+More information about cuneiform can be found at <\fIhttp://launchpad.net/cuneiform-linux/\fR>.
+
+.SH AUTHOR
+cuneiform was written by Cognitive Technologies and Jussi Pakkanen <\fIjpakkane@gmail.com\fR>.
+.PP
+This manual page was written by Daniel Baumann <\fIdaniel@debian.org\fR>, for the Debian project (but may be used by others).
diff --git a/app-text/cuneiform/files/graphicsmagick.diff b/app-text/cuneiform/files/graphicsmagick.diff
new file mode 100644
index 000000000000..265190f40c8a
--- /dev/null
+++ b/app-text/cuneiform/files/graphicsmagick.diff
@@ -0,0 +1,43 @@
+Description: Use GraphicsMagick instead of ImageMagick.
+Author: Jakub Wilk <jwilk@debian.org>
+Forwarded: not-needed
+Last-Update: 2011-01-21
+
+--- a/cuneiform_src/cli/cuneiform-cli.cpp
++++ b/cuneiform_src/cli/cuneiform-cli.cpp
+@@ -341,6 +341,10 @@
+ Magick::InitializeMagick("");
+ #endif
+
++#ifdef USE_MAGICK
++ Magick::InitializeMagick("");
++#endif
++
+ dib = read_file(infilename);
+ if(!dib) // Error msg is already printed so just get out.
+ return 1;
+--- a/cuneiform_src/CMakeLists.txt
++++ b/cuneiform_src/CMakeLists.txt
+@@ -34,15 +34,16 @@
+
+ add_definitions(-D_USE_RVERLINE_)
+
+-find_package(ImageMagick COMPONENTS Magick++)
+-if(ImageMagick_Magick++_FOUND)
++include(FindPkgConfig)
++pkg_check_modules(GraphicsMagick QUIET GraphicsMagick++)
++if(GraphicsMagick_FOUND)
+ set(USE_MAGICK TRUE)
+- include_directories(${ImageMagick_Magick++_INCLUDE_DIR})
+- message(STATUS "ImageMagick++ found at ${ImageMagick_Magick++_INCLUDE_DIR}.")
+- set(cli_ext_libs ${ImageMagick_Magick++_LIBRARY})
++ include_directories(${GraphicsMagick_INCLUDE_DIRS})
++ message(STATUS "GraphicsMagick++ found at ${GraphicsMagick_INCLUDE_DIRS}.")
++ set(cli_ext_libs ${GraphicsMagick_LIBRARIES})
+ else()
+ set(USE_MAGICK FALSE)
+- message(STATUS "ImageMagick++ not found. Only uncompressed BMP images supported.")
++ message(STATUS "GraphicsMagick++ not found. Only uncompressed BMP images supported.")
+ endif()
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Kern/include/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/Kern/include/config.h)
diff --git a/app-text/cuneiform/files/libm.diff b/app-text/cuneiform/files/libm.diff
new file mode 100644
index 000000000000..0ab16d58274f
--- /dev/null
+++ b/app-text/cuneiform/files/libm.diff
@@ -0,0 +1,25 @@
+Description: Link the leo and r35 libraries with libm.
+Author: Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>, Jakub Wilk <jwilk@debian.org>
+Forwarded: no
+Last-Update: 2011-07-04
+
+--- a/cuneiform_src/Kern/leo/CMakeLists.txt
++++ b/cuneiform_src/Kern/leo/CMakeLists.txt
+@@ -23,6 +23,7 @@
+ msk32
+ r3532
+ std32
++m
+ )
+
+ library_hook(leo32)
+--- a/cuneiform_src/Kern/r35/CMakeLists.txt
++++ b/cuneiform_src/Kern/r35/CMakeLists.txt
+@@ -3,6 +3,6 @@
+
+ set_property(TARGET r3532 PROPERTY COMPILE_DEFINITIONS __R35__)
+
+-target_link_libraries(r3532 mmx32 std32 cfcompat)
++target_link_libraries(r3532 mmx32 std32 cfcompat m)
+
+ library_hook(r3532)