summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-13 20:31:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-13 20:34:36 +0100
commitbf5b580a8c8789604547da565180411b3b858e02 (patch)
tree1a4055ff2821fc6f1ae1271b96c037c13d309e9f /app-text/diffpdf/diffpdf-2.1.3-r2.ebuild
parentdev-db/percona-xtrabackup: amd64 stable wrt bug #648262 (diff)
downloadgentoo-bf5b580a8c8789604547da565180411b3b858e02.tar.gz
gentoo-bf5b580a8c8789604547da565180411b3b858e02.tar.bz2
gentoo-bf5b580a8c8789604547da565180411b3b858e02.zip
app-text/diffpdf: Add missing DEPENDs, switch to https
Closes: https://bugs.gentoo.org/650432 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/diffpdf/diffpdf-2.1.3-r2.ebuild')
-rw-r--r--app-text/diffpdf/diffpdf-2.1.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/diffpdf/diffpdf-2.1.3-r2.ebuild b/app-text/diffpdf/diffpdf-2.1.3-r2.ebuild
new file mode 100644
index 000000000000..379468357300
--- /dev/null
+++ b/app-text/diffpdf/diffpdf-2.1.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop qmake-utils
+
+DESCRIPTION="Program that textually or visually compares two PDF files"
+HOMEPAGE="https://www.qtrac.eu/diffpdf.html"
+SRC_URI="http://www.qtrac.eu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[qt5]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=( "${FILESDIR}"/${P}-qt5.patch )
+
+src_configure() {
+ $(qt5_get_bindir)/lrelease diffpdf.pro || die "Generating translations failed"
+ eqmake5 PREFIX="${EPREFIX}/usr" diffpdf.pro
+}
+
+src_install() {
+ einstalldocs
+ dobin diffpdf
+ doman diffpdf.1
+ domenu "${FILESDIR}"/${PN}.desktop
+ newicon images/icon.png ${PN}.png
+}