summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-03-29 13:08:13 -0500
committerBen Kohler <bkohler@gentoo.org>2021-03-29 13:08:13 -0500
commit79be1cf1b3c0487aa237b9a82922f06d4d401fc0 (patch)
tree238f1f80af1eeee3ea9b8311e3ba727164ef9a3f /app-text/discount
parentdev-util/catalyst: restrict snakeoil to <0.9.6 (diff)
downloadgentoo-79be1cf1b3c0487aa237b9a82922f06d4d401fc0.tar.gz
gentoo-79be1cf1b3c0487aa237b9a82922f06d4d401fc0.tar.bz2
gentoo-79be1cf1b3c0487aa237b9a82922f06d4d401fc0.zip
app-text/discount: fix prefix paths
Fixes the missing /'s in pkgconfig file Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/discount-2.2.7-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-text/discount/discount-2.2.7-r1.ebuild b/app-text/discount/discount-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..1ecc2092dae3
--- /dev/null
+++ b/app-text/discount/discount-2.2.7-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 sparc x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/gethopt-undefined.patch )
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --prefix="${EPREFIX}/usr"
+ --mandir="${EPREFIX}/usr/share/man"
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ "${configure_call[@]}" || die
+}
+
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}