summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-04-19 12:42:04 -0500
committerBen Kohler <bkohler@gentoo.org>2021-04-19 12:51:39 -0500
commitd22770a3d20a1b8dc5fa3fb653447b8fe43f2928 (patch)
treefd8c66459db54d46e8b2fe8e5ddcfe682f800028 /app-text/discount
parentsys-cluster/minikube: Bump to version 1.19.0 (diff)
downloadgentoo-d22770a3d20a1b8dc5fa3fb653447b8fe43f2928.tar.gz
gentoo-d22770a3d20a1b8dc5fa3fb653447b8fe43f2928.tar.bz2
gentoo-d22770a3d20a1b8dc5fa3fb653447b8fe43f2928.zip
app-text/discount: drop old
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/discount-2.2.7.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/app-text/discount/discount-2.2.7.ebuild b/app-text/discount/discount-2.2.7.ebuild
deleted file mode 100644
index a5a6091733f8..000000000000
--- a/app-text/discount/discount-2.2.7.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="A Markdown-to HTML translator written in C"
-HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
-SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="minimal test"
-RESTRICT="!test? ( test )"
-
-PATCHES=( "${FILESDIR}"/gethopt-undefined.patch )
-
-src_prepare() {
- default
-
- # for QA, we remove the Makefile’s usage of install -s.
- # Drop ldconfig invocation.
- # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
- # at that point).
- sed -i \
- -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
- -e 's/\(LDCONFIG=\).*/\1:/' \
- -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
- configure.inc || die "sed configure.inc failed"
-}
-
-src_configure() {
- local configure_call=(
- ./configure.sh
- --libdir="${EPREFIX}"usr/"$(get_libdir)"
- --prefix="${EPREFIX}"usr
- --mandir="${EPREFIX}"usr/share/man
- --shared
- --pkg-config
- $(usex minimal '' --enable-all-features)
- # Enable deterministic HTML generation behavior. Otherwise, will
- # actually call rand() as part of its serialization code...
- --debian-glitch
- )
- einfo "Running ${configure_call[@]}"
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- "${configure_call[@]}" || die
-}
-
-src_compile() {
- emake libmarkdown
- emake
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- $(usex minimal install install.everything) \
- SAMPLE_PFX="${PN}-"
-}
-
-pkg_postinst() {
- if ! use minimal; then
- elog 'Sample binaries with overly-generic names have been'
- elog "prefixed with \"${PN}-\"."
- fi
-}