summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/docbook-xml-simple-dtd/docbook-xml-simple-dtd-1.0-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/docbook-xml-simple-dtd/docbook-xml-simple-dtd-1.0-r2.ebuild')
-rw-r--r--app-text/docbook-xml-simple-dtd/docbook-xml-simple-dtd-1.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/docbook-xml-simple-dtd/docbook-xml-simple-dtd-1.0-r2.ebuild b/app-text/docbook-xml-simple-dtd/docbook-xml-simple-dtd-1.0-r2.ebuild
new file mode 100644
index 000000000000..dade633990db
--- /dev/null
+++ b/app-text/docbook-xml-simple-dtd/docbook-xml-simple-dtd-1.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit sgml-catalog
+
+MY_PN="docbook-simple"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Simplified Docbook DTD for XML"
+HOMEPAGE="http://www.oasis-open.org/docbook/"
+SRC_URI="http://www.oasis-open.org/docbook/xml/simple/${PV}/${MY_P}.zip"
+
+LICENSE="docbook"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=">=app-text/build-docbook-catalog-1.6"
+DEPEND=">=app-arch/unzip-5.41"
+
+S=${WORKDIR}
+
+sgml-catalog_cat_include "/etc/sgml/xml-simple-docbook-${PV}.cat" \
+ "/usr/share/sgml/docbook/${P#docbook-}/catalog"
+
+src_install() {
+ insinto /usr/share/sgml/docbook/${P#docbook-}
+ doins *.dtd *.mod *.css
+
+ newins "${FILESDIR}"/${P}.cat catalog
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+ sgml-catalog_pkg_postinst
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+ sgml-catalog_pkg_postrm
+}