summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-11 03:12:22 +0000
committerSam James <sam@gentoo.org>2021-02-11 03:12:22 +0000
commitb4d9ef28d653ca5246e3821460265944c8106192 (patch)
treec62792fdbea9cdc962f757d1b84c58b881292d13 /app-text/docbook2X/docbook2X-0.8.8-r4.ebuild
parentapp-office/mdbtools: bump to 0.9.1 (diff)
downloadgentoo-b4d9ef28d653ca5246e3821460265944c8106192.tar.gz
gentoo-b4d9ef28d653ca5246e3821460265944c8106192.tar.bz2
gentoo-b4d9ef28d653ca5246e3821460265944c8106192.zip
app-text/docbook2X: port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/docbook2X/docbook2X-0.8.8-r4.ebuild')
-rw-r--r--app-text/docbook2X/docbook2X-0.8.8-r4.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild b/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild
index 53121b0e749e..bd850d269574 100644
--- a/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild
+++ b/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-AUTOTOOLS_AUTORECONF=1 #290284
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Tools to convert docbook to man and info"
SRC_URI="mirror://sourceforge/docbook2x/${P}.tar.gz"
@@ -35,23 +34,28 @@ PATCHES=(
# bug #296112
"${FILESDIR}/${P}-drop-htmldir.patch"
)
+
src_prepare() {
+ default
+
sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die 'sed on configure.ac failed'
- autotools-utils_src_prepare
+ # bug #290284
+ eautoreconf
}
src_configure() {
local myeconfargs=(
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
--with-xslt-processor=libxslt
--program-transform-name='/^docbook2/s,$,.pl,'
)
- autotools-utils_src_configure
+
+ econf "${myeconfargs[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
+
dosym docbook2man.pl /usr/bin/docbook2x-man
dosym docbook2texi.pl /usr/bin/docbook2x-texi
}