summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-22 23:37:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-22 23:59:47 +0200
commitea10335f350501cef119c15fb680762f9a55086a (patch)
tree8ec8593253bafe97447851d8ffdec77c2f16a6e9 /app-text/ebook-tools/ebook-tools-0.2.2-r2.ebuild
parentkde-plasma/xembed-sni-proxy: 5.20.1.1 version (tarball only) bump (diff)
downloadgentoo-ea10335f350501cef119c15fb680762f9a55086a.tar.gz
gentoo-ea10335f350501cef119c15fb680762f9a55086a.tar.bz2
gentoo-ea10335f350501cef119c15fb680762f9a55086a.zip
app-text/ebook-tools: EAPI-7, cmake.eclass, crashfix
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/ebook-tools/ebook-tools-0.2.2-r2.ebuild')
-rw-r--r--app-text/ebook-tools/ebook-tools-0.2.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/ebook-tools/ebook-tools-0.2.2-r2.ebuild b/app-text/ebook-tools/ebook-tools-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..b8b20f0bdac3
--- /dev/null
+++ b/app-text/ebook-tools/ebook-tools-0.2.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tools for accessing and converting various ebook file formats"
+HOMEPAGE="https://sourceforge.net/projects/ebook-tools/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+lit2epub"
+
+DEPEND="
+ dev-libs/libxml2
+ >=dev-libs/libzip-1.7.2:=
+"
+RDEPEND="${DEPEND}
+ lit2epub? ( app-text/convertlit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-crashfix.patch"
+ "${FILESDIR}/${P}-fvisibility-hidden.patch"
+ "${FILESDIR}/${P}-libzip-cmake.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ use lit2epub || sed -e "\|lit2epub|d" -i src/tools/CMakeLists.txt || die
+}