summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-01-21 12:48:03 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-01-21 12:48:03 +0700
commitb83b491348e98652b22f8d3310da2ea0299b3b1c (patch)
tree250fef7ba50f3f07904585e881a6f2e841519838 /app-text/foliate
parentapp-text/calibre: Bump to version 5.35.0 (diff)
downloadgentoo-b83b491348e98652b22f8d3310da2ea0299b3b1c.tar.gz
gentoo-b83b491348e98652b22f8d3310da2ea0299b3b1c.tar.bz2
gentoo-b83b491348e98652b22f8d3310da2ea0299b3b1c.zip
app-text/foliate: bump to 2.6.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/foliate')
-rw-r--r--app-text/foliate/Manifest1
-rw-r--r--app-text/foliate/foliate-2.6.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/foliate/Manifest b/app-text/foliate/Manifest
index c66e3fbd29ad..6e03f51b327e 100644
--- a/app-text/foliate/Manifest
+++ b/app-text/foliate/Manifest
@@ -1,2 +1,3 @@
DIST foliate-2.6.2.tar.gz 4760966 BLAKE2B 299dd8ab9f489772d18b85749cb312c8ddd4b21855452f87176ddfe068ff9e1e78cb5465fec97dbf70de22e7a773cf0910c11c3be7d0adb19279f4d9813249a1 SHA512 30bff00c34f90bfbd26b9e2b567a7cbcb1243cc5da17ff060762b7f1aafa4159daacee615de7f9bfef7d29d8209c8191094a154564f04321280037d2ec76a63e
DIST foliate-2.6.3.tar.gz 4822251 BLAKE2B c6cedf4f5ae4e728ab2a7fc35a9fa1e9c69f9d2f8af92060b5363675d5e3fc5cb90698f4b184e792852d66a51e90c361b14d38034149304d10cdacc94100dda7 SHA512 b3dd5bc5a02d3f2210b0c7376426a7ea1668a81fa64fea179da2ab1d852778414cce45171143814d2010d6c03b0287dbbc512884107774ec211e24c6ed8127cb
+DIST foliate-2.6.4.tar.gz 4824560 BLAKE2B fd109d76a7cd0cfbff3fb7273b232a7c749922c5e4d782ed4b7dcb63e914a7cc0bd6e7623a509c3117e45ead5c1d7538c57f322742e4e826b88bddc6182abdf1 SHA512 af58efa2c33451617dbf7327b56551557d762ac80f1b489d5da1c5a46ebbfe329052149deb8b2f4c7729a7fd46deccd5500fd96c0a662b731c871c1ad8061cd3
diff --git a/app-text/foliate/foliate-2.6.4.ebuild b/app-text/foliate/foliate-2.6.4.ebuild
new file mode 100644
index 000000000000..e884210fcfef
--- /dev/null
+++ b/app-text/foliate/foliate-2.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PLOCALES="cs de es eu fr id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+inherit meson plocale xdg-utils gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+src_prepare() {
+ default
+
+ plocale_find_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_po
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}