summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-26 14:38:10 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-26 15:20:04 +0100
commit63cca522128e45910a1583e63c4a8e838c909d49 (patch)
treec82a358a01a107d1ae24b97783765c17a958e763 /app-text/gtkspell
parentdev-ruby/redcarpet: Version bump (diff)
downloadgentoo-63cca522128e45910a1583e63c4a8e838c909d49.tar.gz
gentoo-63cca522128e45910a1583e63c4a8e838c909d49.tar.bz2
gentoo-63cca522128e45910a1583e63c4a8e838c909d49.zip
app-text/gtkspell: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/Manifest1
-rw-r--r--app-text/gtkspell/gtkspell-3.0.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/gtkspell/Manifest b/app-text/gtkspell/Manifest
index 780768af9783..1dbe40d1e331 100644
--- a/app-text/gtkspell/Manifest
+++ b/app-text/gtkspell/Manifest
@@ -1,2 +1,3 @@
DIST gtkspell-2.0.16.tar.gz 351277 SHA256 8fc7dc560167b2cb7193e76aca625a152dc19b0ebf49816b78539cbb90d80d02 SHA512 7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d WHIRLPOOL 58dc258297412b99185f8d284fb4d2ab71ab834aa29e17a9dfb743e93271ae14d517fea2dc886112898f666104300df62b04082c307b3870de4a5d908bf2ae57
DIST gtkspell3-3.0.4.tar.gz 420762 SHA256 fabf8e670c99c1a91996e0e33fa78b7c023f77efb3e11355cf5aa9bcdc43e4a7 SHA512 907b9321b4608ca13c55c1c3a07a648b2d5eb30f0e4a92dca1c27051af254d4ded2444fef1b941f03a96e29e389d868ee15daad4bd7016239cd0dc54bb0f4abb WHIRLPOOL fd07dfd1fc2b4d449083c6847bf2c69d8f11fce2da6a5198a505e75ce6b14b9bd0c66638b5a15c0f0ff8675914355e6f9bbafbbc2096e786f81870c6ab42c1da
+DIST gtkspell3-3.0.7.tar.gz 447648 SHA256 13f2e6d3e2554cc24253ef592074b28c117db33b7a4465c98c69a3e0a4fa3cc2 SHA512 121c32050a3f3fe6868d76ce7783cb4619a9cbca083b45b78e1279e4c86143fe414e60971fed4c505b066449743664b372a06589af9c3e8dd1bafae355f83e47 WHIRLPOOL db0c04e6a6c01bf6929ef92c7f53f0852afab5216854d9dfd028749caa016b9cce94d8c41b0cca6d2e4a5e6005141bb080b1167e4dfeefa4acd0cd8196a8e112
diff --git a/app-text/gtkspell/gtkspell-3.0.7.ebuild b/app-text/gtkspell/gtkspell-3.0.7.ebuild
new file mode 100644
index 000000000000..c4cb2b2b396a
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-3.0.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+MY_P="${PN}3-${PV}"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="3/0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection vala"
+
+RDEPEND="
+ >=app-text/enchant-1.1.6
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-libs/pango-1.8.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}