summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-03 16:05:08 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-03 18:15:31 +0200
commita4c44773909e4c6807f8e8ac3c21550e1c031eaf (patch)
tree6905ab84b86a4cf999fd2cd79f43db554da3cf2d /app-text/gtkspell
parentkde-frameworks/syntax-highlighting: Drop 5.37.0 (r0) (diff)
downloadgentoo-a4c44773909e4c6807f8e8ac3c21550e1c031eaf.tar.gz
gentoo-a4c44773909e4c6807f8e8ac3c21550e1c031eaf.tar.bz2
gentoo-a4c44773909e4c6807f8e8ac3c21550e1c031eaf.zip
app-text/gtkspell: version bump 3.0.7 → 3.0.9, bug #629760
Closes: https://bugs.gentoo.org/show_bug.cgi?id=629760 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/Manifest1
-rw-r--r--app-text/gtkspell/gtkspell-3.0.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/gtkspell/Manifest b/app-text/gtkspell/Manifest
index 40eead8fd6e4..3b601d39910e 100644
--- a/app-text/gtkspell/Manifest
+++ b/app-text/gtkspell/Manifest
@@ -1,2 +1,3 @@
DIST gtkspell-2.0.16.tar.gz 351277 SHA256 8fc7dc560167b2cb7193e76aca625a152dc19b0ebf49816b78539cbb90d80d02 SHA512 7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d WHIRLPOOL 58dc258297412b99185f8d284fb4d2ab71ab834aa29e17a9dfb743e93271ae14d517fea2dc886112898f666104300df62b04082c307b3870de4a5d908bf2ae57
DIST gtkspell3-3.0.7.tar.gz 447648 SHA256 13f2e6d3e2554cc24253ef592074b28c117db33b7a4465c98c69a3e0a4fa3cc2 SHA512 121c32050a3f3fe6868d76ce7783cb4619a9cbca083b45b78e1279e4c86143fe414e60971fed4c505b066449743664b372a06589af9c3e8dd1bafae355f83e47 WHIRLPOOL db0c04e6a6c01bf6929ef92c7f53f0852afab5216854d9dfd028749caa016b9cce94d8c41b0cca6d2e4a5e6005141bb080b1167e4dfeefa4acd0cd8196a8e112
+DIST gtkspell3-3.0.9.tar.xz 298988 SHA256 a4f4a4a2789f7499563e26d96b22d8085222ebe278da47d026b2de782b8b4d26 SHA512 de6cc24ca092067a101996142bf2b3cfb6a5af2170ea4b0185a997e5c88adead7ba53c5a297c3110b3a66dc87d37e429720f972895bb2931f9a033fc006e2eab WHIRLPOOL 18a54c570d603d7e8643647da124b5fe85064b695584f8728e1d753e3cda6e849615317569c9607bd63c6d4abda2ce7e99336718313fc66ec13070df9ea076da
diff --git a/app-text/gtkspell/gtkspell-3.0.9.ebuild b/app-text/gtkspell/gtkspell-3.0.9.ebuild
new file mode 100644
index 000000000000..a5ee97156fc5
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-3.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+MY_P="${PN}3-${PV}"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="3/0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-1.1.6
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-libs/pango-1.8.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}