summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/hd2u
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/hd2u')
-rw-r--r--app-text/hd2u/Manifest1
-rw-r--r--app-text/hd2u/files/hd2u-1.0.0-build.patch25
-rw-r--r--app-text/hd2u/files/hd2u-1.0.3-build.patch25
-rw-r--r--app-text/hd2u/hd2u-1.0.3.ebuild25
-rw-r--r--app-text/hd2u/metadata.xml5
5 files changed, 81 insertions, 0 deletions
diff --git a/app-text/hd2u/Manifest b/app-text/hd2u/Manifest
new file mode 100644
index 000000000000..e0426f88f6a6
--- /dev/null
+++ b/app-text/hd2u/Manifest
@@ -0,0 +1 @@
+DIST hd2u-1.0.3.tgz 60024 SHA256 3c9269e4aa188ddfb1ccadbb9a1906d87f6cbb60b8a2ce71cc6c9f2082ccc890 SHA512 d354964f0ad5392315767b96438d843a5f1d6afe78da5b0c5ea65a3b0b2a61beabff3ecac89df81b9271a14ca443f23dfffeb51815e02b724ad287e42fc2d6cc WHIRLPOOL 36ef7e7beaa27129a12c9dbb7ecbc62c048d2a4db87c68ccb8a2ba5442d9e2bfab6db6a636204331b3c213af45635f2bd6eaa33fd89c60473f684420c423ae1b
diff --git a/app-text/hd2u/files/hd2u-1.0.0-build.patch b/app-text/hd2u/files/hd2u-1.0.0-build.patch
new file mode 100644
index 000000000000..66b32bbc17c7
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.0-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 328016c..f8cc6aa 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -36,7 +36,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+ rebuild: cleanall $(TARGET)
+
+@@ -59,9 +59,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)
diff --git a/app-text/hd2u/files/hd2u-1.0.3-build.patch b/app-text/hd2u/files/hd2u-1.0.3-build.patch
new file mode 100644
index 000000000000..de788e8aa774
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.3-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 2a67b3c..651323d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,7 +42,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+
+ all-optimized: $(TARGET)-optimized
+@@ -98,9 +98,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)
diff --git a/app-text/hd2u/hd2u-1.0.3.ebuild b/app-text/hd2u/hd2u-1.0.3.ebuild
new file mode 100644
index 000000000000..d7a191df3a5f
--- /dev/null
+++ b/app-text/hd2u/hd2u-1.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Dos2Unix like text file converter"
+HOMEPAGE="http://www.megaloman.com/~hany/software/hd2u/"
+SRC_URI="http://www.megaloman.com/~hany/_data/hd2u/${P}.tgz"
+
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="
+ dev-libs/popt"
+RDEPEND="${DEPEND}
+ !app-text/dos2unix"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
diff --git a/app-text/hd2u/metadata.xml b/app-text/hd2u/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-text/hd2u/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>