summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-18 16:02:23 +0000
committerSam James <sam@gentoo.org>2021-01-18 16:02:42 +0000
commit66fbdf6808cf31dae20984f2c0474fcff8de3d1d (patch)
tree0c99dce6dbfb9579dfb16cf6c8e285e13773c1bf /app-text/htmldoc
parentdev-lang/qu-prolog: remove old versions (diff)
downloadgentoo-66fbdf6808cf31dae20984f2c0474fcff8de3d1d.tar.gz
gentoo-66fbdf6808cf31dae20984f2c0474fcff8de3d1d.tar.bz2
gentoo-66fbdf6808cf31dae20984f2c0474fcff8de3d1d.zip
app-text/htmldoc: bump to 1.9.11
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/htmldoc')
-rw-r--r--app-text/htmldoc/Manifest1
-rw-r--r--app-text/htmldoc/htmldoc-1.9.11.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/htmldoc/Manifest b/app-text/htmldoc/Manifest
index 404d247221e8..22ce11af61b4 100644
--- a/app-text/htmldoc/Manifest
+++ b/app-text/htmldoc/Manifest
@@ -1 +1,2 @@
DIST htmldoc-1.8.30-source.tar.gz 3901592 BLAKE2B 1aad75973ce485fdbe15d6db99701f88a0fd48a075014c401cc8fdb1f9031214a148748e6731542ca8df7bfa5e5f4c50ec772dac4231fdd71e70f6b092bd20ac SHA512 713dc67622533dae896745ac8809e43a7f91696715aeb77df2628bd04c0d3e16c8402891499e8e0c10cab793b44114e600d5935b3c76a3cfa303c10897456804
+DIST htmldoc-1.9.11-source.tar.gz 4471815 BLAKE2B a76da0f5129d8d637c440ee1880bdc4c314db02294f8e7387abe28ab7f76a81b47c4670a27d34759f89b82e9b1d7c259d154fac7cb8c2b7caa6e1f99f3a35ebf SHA512 5ee6a61f129be9a7d26c554f1acb533f1edfbf34eefd8f4924e07bcead2680407c68b4e2c9840203d7bb07daf51ea18c422d7c04e33c4b346dd207531f330678
diff --git a/app-text/htmldoc/htmldoc-1.9.11.ebuild b/app-text/htmldoc/htmldoc-1.9.11.ebuild
new file mode 100644
index 000000000000..fb0d4a82ad14
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.9.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs xdg
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+HOMEPAGE="http://www.msweet.org/projects.php?Z1"
+SRC_URI="https://github.com/michaelrsweet/${PN}/releases/download/v${PV}/${P}-source.tar.gz"
+
+IUSE="fltk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ >=media-libs/libpng-1.4:0=
+ virtual/jpeg:0
+ fltk? ( x11-libs/fltk:1 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Make sure not to use the libs htmldoc ships with
+ rm -r jpeg png zlib || die "failed to unbundle jpeg, png, and zlib"
+
+ # Fix the documentation path in a few places. Some Makefiles aren't
+ # autotoolized =(
+ for file in configure doc/Makefile doc/htmldoc.man; do
+ sed -i "${file}" \
+ -e "s:/doc/htmldoc:/doc/${PF}/html:g" \
+ || die "failed to fix documentation path in ${file}"
+ done
+}
+
+src_configure() {
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" DSTROOT="${ED}" econf \
+ $(use_with fltk gui)
+}
+
+src_install() {
+ emake STRIPPROG="true" DSTROOT="${ED}" install
+}