summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-06-02 10:32:10 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-06-02 10:33:16 +0300
commite5a4e48fe6bb76ef62fae3f22601b801dbe59a06 (patch)
tree796c61914600b8ab8d63144e0c4f54f398808123 /app-text/htmldoc
parentmedia-libs/exiftool: Bump to version 10.19 (diff)
downloadgentoo-e5a4e48fe6bb76ef62fae3f22601b801dbe59a06.tar.gz
gentoo-e5a4e48fe6bb76ef62fae3f22601b801dbe59a06.tar.bz2
gentoo-e5a4e48fe6bb76ef62fae3f22601b801dbe59a06.zip
app-text/htmldoc: respect system toolchain settings
If CC and CXX variables are not exported to configure, it ignores system toolchain setup and forces its own compiler preferences, where clang/clang++ are on the first place if found. This is likely not what users want and causes configure failure if CFLAGS/CXXFLAGS contain flag(s) not supported by clang, but supported by gcc. Package-Manager: portage-2.3.0_rc1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-text/htmldoc')
-rw-r--r--app-text/htmldoc/htmldoc-1.8.29.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-text/htmldoc/htmldoc-1.8.29.ebuild b/app-text/htmldoc/htmldoc-1.8.29.ebuild
index db8e07548116..c7cd08aeb8f3 100644
--- a/app-text/htmldoc/htmldoc-1.8.29.ebuild
+++ b/app-text/htmldoc/htmldoc-1.8.29.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=6
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Convert HTML pages into a PDF document"
SRC_URI="http://www.msweet.org/files/project1/${P}-source.tar.bz2"
@@ -36,6 +36,7 @@ src_prepare() {
src_configure() {
local myconf="$(use_with fltk gui)"
+ CC=$(tc-getCC) CXX=$(tc-getCXX) \
econf ${myconf}
# Add missing -lfltk_images to LIBS
if use fltk; then