summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-26 15:29:30 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-26 15:40:19 -0400
commit3c336fe5d14f7cafddde7f99b7611bec8a126f3b (patch)
tree274e37a91d5fdee6ef6a3b20dc22f792ae6ba6d9 /app-text/htp/htp-1.16-r1.ebuild
parentapp-text/groonga: drop old EAPI=5 (diff)
downloadgentoo-3c336fe5d14f7cafddde7f99b7611bec8a126f3b.tar.gz
gentoo-3c336fe5d14f7cafddde7f99b7611bec8a126f3b.tar.bz2
gentoo-3c336fe5d14f7cafddde7f99b7611bec8a126f3b.zip
app-text/htp: drop old EAPI=5
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-text/htp/htp-1.16-r1.ebuild')
-rw-r--r--app-text/htp/htp-1.16-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-text/htp/htp-1.16-r1.ebuild b/app-text/htp/htp-1.16-r1.ebuild
deleted file mode 100644
index 6a5c090922df..000000000000
--- a/app-text/htp/htp-1.16-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An HTML preprocessor"
-HOMEPAGE="http://htp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="Clarified-Artistic"
-SLOT="0"
-KEYWORDS="~alpha ~ppc ~sparc ~x86"
-IUSE=""
-
-# HTP does not use autoconf, have to set options defined in Makefile.config
-
-src_prepare() {
- epatch "${FILESDIR}"/strip.patch #240110
- # let src_test take care of testing
- sed -i -e '/SUBDIRS /s:tests::' Makefile || die
- # don't install doc files with +x perms
- sed -i -e '$aINSTALL += -m644' homepage/ref/{*/,}Makefile || die
- # make src_test abort on failure
- sed -i -e '/DIFF.*FAILED/s/echo/exit 1; :/' tests/Makefile || die
- # the png file in this test isn't fetchable
- sed -i -e 's: width="630" height="331"::' tests/png.html.exp || die
-}
-
-src_compile() {
- emake \
- CCOPT="-c ${CFLAGS} ${CPPFLAGS} -DHAVE_SNPRINTF -DHAVE_VASPRINTF -DHAVE_ASPRINTF" \
- CC="$(tc-getCC)" \
- LINK='$(CC) $(LDFLAGS)'
-}
-
-src_test() {
- emake -C tests
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- prefix='$(DESTDIR)/usr' \
- pkgdocdir='$(DESTDIR)/usr/share/doc/${PF}/html' \
- install
-}