summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-text/htp
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/htp')
-rw-r--r--app-text/htp/htp-1.16-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-text/htp/htp-1.16-r1.ebuild b/app-text/htp/htp-1.16-r1.ebuild
index f3fd15c02c87..6a5c090922df 100644
--- a/app-text/htp/htp-1.16-r1.ebuild
+++ b/app-text/htp/htp-1.16-r1.ebuild
@@ -32,12 +32,11 @@ src_compile() {
emake \
CCOPT="-c ${CFLAGS} ${CPPFLAGS} -DHAVE_SNPRINTF -DHAVE_VASPRINTF -DHAVE_ASPRINTF" \
CC="$(tc-getCC)" \
- LINK='$(CC) $(LDFLAGS)' \
- || die
+ LINK='$(CC) $(LDFLAGS)'
}
src_test() {
- emake -C tests || die
+ emake -C tests
}
src_install() {
@@ -45,5 +44,5 @@ src_install() {
DESTDIR="${D}" \
prefix='$(DESTDIR)/usr' \
pkgdocdir='$(DESTDIR)/usr/share/doc/${PF}/html' \
- install || die
+ install
}