summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-05 11:27:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-10 08:39:48 +0200
commit86a8a61e9c28927f87628df73c2a45e0db5420fd (patch)
treecd01beaf9cce6688cc72611a9090195023d378fc /app-text/htp
parentapp-misc/ttyload: stable for amd64+x86. (diff)
downloadgentoo-86a8a61e9c28927f87628df73c2a45e0db5420fd.tar.gz
gentoo-86a8a61e9c28927f87628df73c2a45e0db5420fd.tar.bz2
gentoo-86a8a61e9c28927f87628df73c2a45e0db5420fd.zip
app-text/htp: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-text/htp')
-rw-r--r--app-text/htp/Manifest1
-rw-r--r--app-text/htp/htp-1.19.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/htp/Manifest b/app-text/htp/Manifest
index 6f72c077b631..32554a498f6a 100644
--- a/app-text/htp/Manifest
+++ b/app-text/htp/Manifest
@@ -1 +1,2 @@
DIST htp-1.16.tar.gz 141133 BLAKE2B 58f0ab7df1400d561ec1994a98ce4fa3acaa3299b51d9382f9baaecbd95a623795d72204617c153fd4e165910fdabd0328e737cccb242be2075edd2573af55c1 SHA512 f33a9497fc3a1d0b95d8e3ee2747583d58626b565644e7c8cc054570458907aac9db42c6fa816b176b0e10db98ec7d1cedb521406035a8e7173e1abd991533a0
+DIST htp-1.19.tar.gz 208683 BLAKE2B 86837290a2f14b8a0337d9eb6a0fa4ad553c5c51074d5df903ee19aa7ba441898199f0649b39b93c35fa3707e4084a284e02d8802c014bf5c0277e3f18d02c98 SHA512 32d82bb42ef877bd815fe45fa81599a1428ad6d3269cbe53a4e686bcfe6d1c12ac2af280462768d488b1983ca67cc521da4ed78cc82d904575ffeff08c7eec1d
diff --git a/app-text/htp/htp-1.19.ebuild b/app-text/htp/htp-1.19.ebuild
new file mode 100644
index 000000000000..962eb9f37525
--- /dev/null
+++ b/app-text/htp/htp-1.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HTML preprocessor"
+HOMEPAGE="http://htp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RESTRICT="test"
+
+QA_PRESTRIPPED="/usr/bin/htp"
+
+src_compile() {
+ emake \
+ CCOPT="-c ${CFLAGS} ${CPPFLAGS} -DHAVE_SNPRINTF -DHAVE_VASPRINTF -DHAVE_ASPRINTF" \
+ CC="$(tc-getCC)" \
+ LINK='$(CC) $(LDFLAGS)'
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix='$(DESTDIR)/usr' \
+ pkgdocdir='$(DESTDIR)/usr/share/doc/${PF}/html' \
+ install
+}