summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/hyperestraier/hyperestraier-1.4.13.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/hyperestraier/hyperestraier-1.4.13.ebuild')
-rw-r--r--app-text/hyperestraier/hyperestraier-1.4.13.ebuild113
1 files changed, 113 insertions, 0 deletions
diff --git a/app-text/hyperestraier/hyperestraier-1.4.13.ebuild b/app-text/hyperestraier/hyperestraier-1.4.13.ebuild
new file mode 100644
index 000000000000..0de09e990768
--- /dev/null
+++ b/app-text/hyperestraier/hyperestraier-1.4.13.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-opt-2 multilib
+
+IUSE="debug java mecab ruby"
+
+DESCRIPTION="a full-text search system for communities"
+HOMEPAGE="http://fallabs.com/hyperestraier/"
+SRC_URI="http://fallabs.com/hyperestraier/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+SLOT="0"
+
+RDEPEND=">=dev-db/qdbm-1.8.75
+ sys-libs/zlib
+ java? ( >=virtual/jre-1.4 )
+ mecab? ( app-text/mecab )
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.4 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ # fix for insecure runpath warning.
+ sed -i \
+ -e "/^LDENV/d" \
+ -e "/^CFLAGS/s/$/ ${CFLAGS}/" \
+ Makefile.in \
+ || die
+ sed -i "/^JAVACFLAGS/s/$/ ${JAVACFLAGS}/" java*/Makefile.in || die
+
+}
+
+src_compile() {
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable mecab) \
+ || die
+ emake || die
+
+ local u d
+
+ for u in java ruby; do
+ if ! use ${u}; then
+ continue
+ fi
+
+ for d in ${u}native ${u}pure; do
+ cd ${d}
+ econf || die
+ emake || die
+ cd -
+ done
+ done
+
+}
+
+src_test() {
+
+ emake -j1 check || die
+
+ local u d
+
+ for u in java ruby; do
+ if ! use ${u}; then
+ continue
+ fi
+
+ for d in ${u}native; do
+ cd ${d}
+ emake -j1 check || die
+ cd -
+ done
+ done
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" MYDOCS= install || die
+ dodoc ChangeLog README* THANKS
+ dohtml doc/{*.html,*.png}
+
+ local u d
+
+ for u in java ruby; do
+ if ! use ${u}; then
+ continue
+ fi
+
+ for d in ${u}native ${u}pure; do
+ cd ${d}
+ emake DESTDIR="${D}" install || die
+ cd -
+ dohtml -r doc/${d}api
+ done
+ done
+
+ if use java; then
+ java-pkg_dojar "${D}"/usr/$(get_libdir)/*.jar
+ rm -f "${D}"/usr/$(get_libdir)/*.jar
+ fi
+
+ rm -f "${D}"/usr/bin/*test
+
+}