summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-12 22:54:15 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-12 22:55:03 +0900
commit3cf933d5bc477823267bbd681721eaa762fb61cf (patch)
tree16ee67b5b94d37595b492a183fe425b99273b64e /app-text/hyperestraier
parentapp-text/hyperestraier: update to EAPI 7 (diff)
downloadgentoo-3cf933d5bc477823267bbd681721eaa762fb61cf.tar.gz
gentoo-3cf933d5bc477823267bbd681721eaa762fb61cf.tar.bz2
gentoo-3cf933d5bc477823267bbd681721eaa762fb61cf.zip
app-text/hyperestraier: fix configure
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-text/hyperestraier')
-rw-r--r--app-text/hyperestraier/files/hyperestraier-configure.patch30
1 files changed, 29 insertions, 1 deletions
diff --git a/app-text/hyperestraier/files/hyperestraier-configure.patch b/app-text/hyperestraier/files/hyperestraier-configure.patch
index 4e747d9c754b..0daee36183c6 100644
--- a/app-text/hyperestraier/files/hyperestraier-configure.patch
+++ b/app-text/hyperestraier/files/hyperestraier-configure.patch
@@ -1,3 +1,13 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -67,6 +67,7 @@
+ SKLIBS = @MYSKLIBS@
+ APPLIBS = @MYAPPLIBS@
+ LDENV = LD_RUN_PATH=/lib:/usr/lib:$(MYLIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
++AR = @AR@
+ RUNENV = LD_LIBRARY_PATH=.:/lib:/usr/lib:$(MYLIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
+ MYPOSTCMD = @MYPOSTCMD@
+
--- a/configure.in
+++ b/configure.in
@@ -24,24 +24,6 @@
@@ -33,8 +43,17 @@
enables="$enables (debug)"
stable="yes"
fi
-@@ -187,19 +169,20 @@
+@@ -180,26 +161,28 @@
+ then
+ MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+ fi
+- if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++ if $CC --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+ then
+ MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+ fi
fi
++AC_CHECK_TOOL(AR, ar)
# Underlying libraries
+PKG_PROG_PKG_CONFIG
@@ -110,6 +129,15 @@
#================================================================
+@@ -134,7 +112,7 @@
+ then
+ MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+ fi
+-if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++if $CC --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+ then
+ MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+ fi
@@ -158,7 +136,7 @@
AC_CHECK_LIB(lzo2, main)
AC_CHECK_LIB(bz2, main)