summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-15 13:34:28 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-15 13:37:19 +0200
commit091b33062e5e103c9652118b66a01835709d39fe (patch)
tree1f18c0f780b58d98024b531f2206a27078a01ade /app-text/jo
parentwww-client/opera-developer: Version 69.0.3660.0 (diff)
downloadgentoo-091b33062e5e103c9652118b66a01835709d39fe.tar.gz
gentoo-091b33062e5e103c9652118b66a01835709d39fe.tar.bz2
gentoo-091b33062e5e103c9652118b66a01835709d39fe.zip
app-text/jo: Add live ebuild
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text/jo')
-rw-r--r--app-text/jo/jo-99999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/jo/jo-99999.ebuild b/app-text/jo/jo-99999.ebuild
new file mode 100644
index 000000000000..430a4993680b
--- /dev/null
+++ b/app-text/jo/jo-99999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools bash-completion-r1 git-r3
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${ED}/$(get_bashcompdir)"/jo{.bash,} || die
+}