summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-16 03:34:26 +0100
committerSam James <sam@gentoo.org>2021-08-16 03:34:26 +0100
commit0e53f989f919b8721b66ef63776ad10d19f34a2b (patch)
tree90e92de4080cf045d51d682a7b2ad0cdb9bb4216 /app-text/lesspipe
parentsys-apps/rng-tools: add 6.14 (diff)
downloadgentoo-0e53f989f919b8721b66ef63776ad10d19f34a2b.tar.gz
gentoo-0e53f989f919b8721b66ef63776ad10d19f34a2b.tar.bz2
gentoo-0e53f989f919b8721b66ef63776ad10d19f34a2b.zip
app-text/lesspipe: add 1.88
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-1.88.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index 2bab6100fc5a..6075dbbc12c8 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,3 +1,4 @@
DIST lesspipe-1.85.tar.gz 120568 BLAKE2B d2c00f4121dc1bbed6b82220dac038068bbff87c732385399542cb212d4664c74d018db07829f90c38e938cb8623a443888c74b0d003fff725d0ddf207d8109e SHA512 420d087b9fc9783b9404855e4656b88c10852502bd2f1931978b7dc7ff15eba1a375b217184480f9b341322c12e7336d0861ba9c2f673f2b2a7fb340a381f5b2
DIST lesspipe-1.86.tar.gz 120910 BLAKE2B 1065bd95707991380cee8b1be917ae66a6537fdd721e9ec0c326b1ce3358ae518dd28902505967fc086e57e9d3e603e27a328f38c79ae38fe70e5e2a8306b59a SHA512 88a890b91ff3d889f32f23d85d76ef96947e8f1175d54d4301e8891587e87bf1c0a147f1fd5391e52badf4ee31229d337b97c5d5e5f74f4dde966eb93294cfb2
DIST lesspipe-1.87.tar.gz 120935 BLAKE2B 3c6348c4a00cddfdf11832fda58582483e07e94a1834d6128329e2902356990f1c590300508127a365179a43b0d5c0c82bafd5b0a3a5945270084c8a94e1e3a2 SHA512 774168c6cbb7b13f2efaf7d19a1bba378e51c25553b8ea0bd9783de3a6d0bf7a3f7abf79332b40180eaa1f67274edebf51cb90c13a0fbd4051f33cecc20124b2
+DIST lesspipe-1.88.tar.gz 121053 BLAKE2B 9d754c38b7e13f11799c22ac75d1a3636a1c5a38f1f83bda5b41d24ae9a6ecda0191190edf72132b0bb4e09a16aa3696cad906269ad09c9d2e1f26b44cc6937e SHA512 ece17095e2ba4cabeb689f7a4eb2e04297ec4fd3910af719a067487127bea3f11d2946542048cf152cf9d269152fc5dfa4a57abb0ccd8f60c5e1f9f106f23559
diff --git a/app-text/lesspipe/lesspipe-1.88.ebuild b/app-text/lesspipe/lesspipe-1.88.ebuild
new file mode 100644
index 000000000000..bc53c82f7b8e
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.88.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Tests are broken in 1.84, 1.85.
+# Still fragile in 1.88. Passes when lesspipe is not installed.
+# Please check again on bumps!
+# bug #734896
+RESTRICT="test"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_prepare() {
+ default
+
+ # Drop a failing test. Not ideal, however:
+ # The test suite for this package is pretty fragile; it's more valuable
+ # to have _something_ failing/passing overall, than relying on a single
+ # test which seems to fail due to an unpredictable external command.
+ sed -i -e '/#needs pstotext ps2ascii/d' TESTCMDS || die
+}
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_test() {
+ # LC_ALL=C manages to fix one test failure
+ LC_ALL=C ./test.pl -d || die "Tests failed!"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}