summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-07 10:52:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-07 10:52:49 +0100
commitf54366ab6f3f6a0e9dad9b103672c3a92c8b0a85 (patch)
tree5125e4a8d394aa05c182529d95d1bfa46870e766 /app-text/libabw
parentapp-text/libmspub: 0.1.3 version bump (diff)
downloadgentoo-f54366ab6f3f6a0e9dad9b103672c3a92c8b0a85.tar.gz
gentoo-f54366ab6f3f6a0e9dad9b103672c3a92c8b0a85.tar.bz2
gentoo-f54366ab6f3f6a0e9dad9b103672c3a92c8b0a85.zip
app-text/libabw: 0.1.2 version bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/libabw')
-rw-r--r--app-text/libabw/Manifest1
-rw-r--r--app-text/libabw/libabw-0.1.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/libabw/Manifest b/app-text/libabw/Manifest
index 959e4f00a7ae..24dfe74af611 100644
--- a/app-text/libabw/Manifest
+++ b/app-text/libabw/Manifest
@@ -1 +1,2 @@
DIST libabw-0.1.1.tar.xz 287628 BLAKE2B c8873512d7bb4c6594330dd35f044a6d6fb7bd07f4b915b5f0d0752ae36c9c6d2c8a5e7e7f66947fb5c27256e0701214b3fe171e1f52c09cfd42bbf106bc689e SHA512 853dd86ecc79e8590d3163e05e145ad66240ae3cf12d206d021775a94bfb33d70aa5acdcdd193ac747baeae1ba0eed18099ea6f4515be23bdd70b431e96c4b1a
+DIST libabw-0.1.2.tar.xz 318400 BLAKE2B ba25542da0d6568530241892dbdba72d2b0dcf667b50e0c1a4e656e0facf82bf77ca8eff8db4d6e57ab699f12d8dad511d32aee291541ffe6460b2ee98590b68 SHA512 a365c1aa047a97a86eee6bce8463646bdf248a51013139ee288402a832fd545586e072d7c7fc11a56f42e3637de9e922197be20d0587e53c51fd80ced409a6cd
diff --git a/app-text/libabw/libabw-0.1.2.ebuild b/app-text/libabw/libabw-0.1.2.ebuild
new file mode 100644
index 000000000000..9db45bfc4cfa
--- /dev/null
+++ b/app-text/libabw/libabw-0.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library parsing abiword documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libabw"
+SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}