summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-27 23:12:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-27 23:42:46 +0200
commita0afdedf31f36c4bd0d4204f1d7caaa085e5206b (patch)
treedfc3cb9448e71b8557f39a87ec3f39ab648306c8 /app-text/libmwaw/libmwaw-0.3.14.ebuild
parentapp-text/libstaroffice: 0.0.6 version bump (diff)
downloadgentoo-a0afdedf31f36c4bd0d4204f1d7caaa085e5206b.tar.gz
gentoo-a0afdedf31f36c4bd0d4204f1d7caaa085e5206b.tar.bz2
gentoo-a0afdedf31f36c4bd0d4204f1d7caaa085e5206b.zip
app-text/libmwaw: 0.3.14 version bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-text/libmwaw/libmwaw-0.3.14.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-0.3.14.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/libmwaw/libmwaw-0.3.14.ebuild b/app-text/libmwaw/libmwaw-0.3.14.ebuild
new file mode 100644
index 000000000000..7dde090fa754
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="doc static-libs tools"
+
+RDEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --enable-zip \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}