summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-22 12:59:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-22 18:33:43 +0200
commit964576cc2996298f8c4f547b103925503f3626b1 (patch)
tree64bf86f26d341361c59009bbf0aa3e9d2e9e1973 /app-text/libmwaw/libmwaw-0.3.15.ebuild
parentapp-text/libmwaw: EAPI-7 bump (diff)
downloadgentoo-964576cc2996298f8c4f547b103925503f3626b1.tar.gz
gentoo-964576cc2996298f8c4f547b103925503f3626b1.tar.bz2
gentoo-964576cc2996298f8c4f547b103925503f3626b1.zip
app-text/libmwaw: 0.3.15 version bump
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libmwaw/libmwaw-0.3.15.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-0.3.15.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/libmwaw/libmwaw-0.3.15.ebuild b/app-text/libmwaw/libmwaw-0.3.15.ebuild
new file mode 100644
index 000000000000..cc207bd575ba
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc static-libs tools"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}