summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/libodfgen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/libodfgen')
-rw-r--r--app-text/libodfgen/Manifest3
-rw-r--r--app-text/libodfgen/libodfgen-0.0.4.ebuild39
-rw-r--r--app-text/libodfgen/libodfgen-0.1.3.ebuild41
-rw-r--r--app-text/libodfgen/libodfgen-0.1.4.ebuild41
-rw-r--r--app-text/libodfgen/libodfgen-9999.ebuild48
-rw-r--r--app-text/libodfgen/metadata.xml8
6 files changed, 180 insertions, 0 deletions
diff --git a/app-text/libodfgen/Manifest b/app-text/libodfgen/Manifest
new file mode 100644
index 000000000000..3843ee5114af
--- /dev/null
+++ b/app-text/libodfgen/Manifest
@@ -0,0 +1,3 @@
+DIST libodfgen-0.0.4.tar.xz 296224 SHA256 8f7a46f05417afbe957d0c3f88e375631b8651ea99bb2c231595408bc4224099 SHA512 5d637139c30ce24e11f4ae102b3374c95afb66e6300ef6f45dd4c2957b36bc3c56da53d49b2b6c8ba9bbadc118dffeab11421b85a9ba47e1ccf101bc1cd75e1d WHIRLPOOL 3382383a1a6edbdc183fe649812ee0285294845fdc5c47a8329cadf2fe0374f20189a9e6db0fc166d096c85400466ed56dcc1709e6728fe6b0e1e5b4c3f8c468
+DIST libodfgen-0.1.3.tar.xz 334744 SHA256 d3a09d987e9c0955846cad1e8a885a9c7a76bfaff75d4c1b5626844c62808eba SHA512 c93abc1ce100c38876b70c1458515086f93b1c376df905fd05d428f69e3f7c709a26c38b18583f878a7f2850b069b99917aeb44426d6decb3be3081bec039c86 WHIRLPOOL 74d17ed0320807cf4ddbd92452a59205b0195694c26692fda8c201964df3f56a38c27b65b9bcdaee58469bbf1e91c4a901903de9bb9e6c6050854678f611d2e7
+DIST libodfgen-0.1.4.tar.xz 356480 SHA256 249b5ed8e1acc0fee32b4381b31b4ad9453b674d4f13886bda5e9dd2b4a5f1e1 SHA512 b9229a6aea7dab1de2315a3632a3494bb785fafa8035e8f323176e76553f05cef8fc7b3e0b5fe6c154b4d8bd7ef69526703c580629dcac63adfd552539fcad69 WHIRLPOOL de779e605c2f15b95108df405a860a9285d756c374681df416c26dcd77f5b893c07a3e89ae6d2a62275b518c921f8a4930ff29886607aada8d6bcf0d055c9462
diff --git a/app-text/libodfgen/libodfgen-0.0.4.ebuild b/app-text/libodfgen/libodfgen-0.0.4.ebuild
new file mode 100644
index 000000000000..097b15d07c28
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ =app-text/libetonyek-0.0*
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libodfgen/libodfgen-0.1.3.ebuild b/app-text/libodfgen/libodfgen-0.1.3.ebuild
new file mode 100644
index 000000000000..63251dceaecf
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+# git://git.code.sf.net/p/libwpd/libodfgen
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libodfgen/libodfgen-0.1.4.ebuild b/app-text/libodfgen/libodfgen-0.1.4.ebuild
new file mode 100644
index 000000000000..63251dceaecf
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+# git://git.code.sf.net/p/libwpd/libodfgen
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libodfgen/libodfgen-9999.ebuild b/app-text/libodfgen/libodfgen-9999.ebuild
new file mode 100644
index 000000000000..d9557712f6c2
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/libodfgen"
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libodfgen/metadata.xml b/app-text/libodfgen/metadata.xml
new file mode 100644
index 000000000000..62fc7320abb5
--- /dev/null
+++ b/app-text/libodfgen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <upstream>
+ <remote-id type="sourceforge">libwpd</remote-id>
+ </upstream>
+</pkgmetadata>