summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-21 13:47:51 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-21 13:49:16 +0300
commit404f4e19d5c192031a9a641facbc572f91caa914 (patch)
tree9a4c683272966f7b50e13d89bb470f18d6e0f77d /app-text/libpaper/libpaper-1.1.28.ebuild
parentdev-db/spatialite: Drop 4.3.0-r1 (diff)
downloadgentoo-404f4e19d5c192031a9a641facbc572f91caa914.tar.gz
gentoo-404f4e19d5c192031a9a641facbc572f91caa914.tar.bz2
gentoo-404f4e19d5c192031a9a641facbc572f91caa914.zip
app-text/libpaper: Version bump (v1.1.28)
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-text/libpaper/libpaper-1.1.28.ebuild')
-rw-r--r--app-text/libpaper/libpaper-1.1.28.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-1.1.28.ebuild b/app-text/libpaper/libpaper-1.1.28.ebuild
new file mode 100644
index 000000000000..30cbd0b143cb
--- /dev/null
+++ b/app-text/libpaper/libpaper-1.1.28.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="http://packages.debian.org/unstable/source/libpaper"
+SRC_URI="mirror://debian/pool/main/libp/libpaper/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DOCS=( README ChangeLog debian/changelog )
+
+src_prepare() {
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ einstalldocs
+
+ dodir /etc
+ (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
+ || die "papersize config failed"
+
+ if ! has_version app-text/libpaper ; then
+ echo
+ elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
+ echo
+ fi
+}