summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-03 11:58:26 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-03 12:00:32 -0700
commitfc9bf6cfb34da41dd73f64be5854b51302815238 (patch)
tree2eb86f04779a7d08e64e8ae1f5d1bbc700e118ba /app-text/libspectre
parentx11-libs/libnotify: Version bump to 0.7.11 (diff)
downloadgentoo-fc9bf6cfb34da41dd73f64be5854b51302815238.tar.gz
gentoo-fc9bf6cfb34da41dd73f64be5854b51302815238.tar.bz2
gentoo-fc9bf6cfb34da41dd73f64be5854b51302815238.zip
app-text/libspectre: Version bump to 0.2.10
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/libspectre')
-rw-r--r--app-text/libspectre/Manifest1
-rw-r--r--app-text/libspectre/libspectre-0.2.10.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
index 45abcebe3af8..5a0e02e4ad89 100644
--- a/app-text/libspectre/Manifest
+++ b/app-text/libspectre/Manifest
@@ -1 +1,2 @@
+DIST libspectre-0.2.10.tar.gz 436690 BLAKE2B 8c1d25225a212b7e8d2bab7cffa4298509450cf727e38d0be22d27ed5fb161a0f838967afa3f8aa265c2bd243431bbfb92976cf51ee52ee7d3b0479000215546 SHA512 01738f452f99878beaa528b15d8df463ca22d625306d636e1a6199ade9f068d284f1def3882e954a06e5f066937343f79d0c2197fbb19ab53ef1ab0540c72f2f
DIST libspectre-0.2.9.tar.gz 433384 BLAKE2B ed75a7013763a86c0f0702e0e47dcfb8401db6c957ed4851ecc85e27db6a49c8d4dae6443b302bcce5b0ae0da18dce3294a010eee5531a253020a650c19388c5 SHA512 7c24b5c83c6d356c89417d09dc76566afbe886ec189fe80d030a239c23ad25b061db071768117fa06805aa3d86f749fb232b7491bd7d467f26a40e348e74d5d2
diff --git a/app-text/libspectre/libspectre-0.2.10.ebuild b/app-text/libspectre/libspectre-0.2.10.ebuild
new file mode 100644
index 000000000000..04e44d862e05
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for rendering Postscript documents"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND=">=app-text/ghostscript-gpl-9.53.0:="
+DEPEND="${RDEPEND}"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug asserts)
+ $(use_enable debug checks)
+ --disable-static
+ --disable-test
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}