summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-29 23:14:50 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-29 23:15:41 -0400
commit65f60cb497c44cc45f0e02f3661cfce3c5661e2c (patch)
treed497262d2a692aec1bb3122ef7719f8b19a060bd /app-text/manpager/manpager-1.ebuild
parentdev-python/selenium; bump, remove unneeded IUSE doc (diff)
downloadgentoo-65f60cb497c44cc45f0e02f3661cfce3c5661e2c.tar.gz
gentoo-65f60cb497c44cc45f0e02f3661cfce3c5661e2c.tar.bz2
gentoo-65f60cb497c44cc45f0e02f3661cfce3c5661e2c.zip
app-text/manpager: initial package #184604
Simple wrapper for colorizing man page output.
Diffstat (limited to 'app-text/manpager/manpager-1.ebuild')
-rw-r--r--app-text/manpager/manpager-1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/manpager/manpager-1.ebuild b/app-text/manpager/manpager-1.ebuild
new file mode 100644
index 000000000000..9fd9c2672166
--- /dev/null
+++ b/app-text/manpager/manpager-1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enable colorization of man pages"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_compile() {
+ local cmd=(
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}
+ "${FILESDIR}"/manpager.c -o ${PN}
+ )
+ echo "${cmd[@]}"
+ "${cmd[@]}" || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/env.d
+ echo "MANPAGER=manpager" | newins - 00manpager
+}