summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoão Santos <joaompssantos@gmail.com>2018-08-26 10:25:09 +0100
committerMichał Górny <mgorny@gentoo.org>2018-09-16 21:39:15 +0200
commit987587f75a9028966d924a4a8833fd6e187d3995 (patch)
tree9642c4651f1dcd418bf9e54b701dee50b7292a73 /app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild
parentprofiles: Mask media-libs/celt for removal (diff)
downloadgentoo-987587f75a9028966d924a4a8833fd6e187d3995.tar.gz
gentoo-987587f75a9028966d924a4a8833fd6e187d3995.tar.bz2
gentoo-987587f75a9028966d924a4a8833fd6e187d3995.zip
app-text/master-pdf-editor: version bump to 5.1.30
Diffstat (limited to 'app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild')
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild
new file mode 100644
index 000000000000..1ed334d5153a
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.1.30.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils desktop
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+COMMON_DEPEND="
+ >=media-gfx/sane-backends-1.0
+ >=dev-qt/qtsvg-5.4.1:5
+ >=dev-qt/qtnetwork-5.4.1:5
+ >=dev-qt/qtgui-5.4.1:5
+ >=dev-qt/qtprintsupport-5.4.1:5
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}