summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/mupdf/mupdf-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/mupdf/mupdf-9999.ebuild')
-rw-r--r--app-text/mupdf/mupdf-9999.ebuild128
1 files changed, 128 insertions, 0 deletions
diff --git a/app-text/mupdf/mupdf-9999.ebuild b/app-text/mupdf/mupdf-9999.ebuild
new file mode 100644
index 000000000000..420f7075d015
--- /dev/null
+++ b/app-text/mupdf/mupdf-9999.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-2 multilib toolchain-funcs
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="http://mupdf.com/"
+EGIT_REPO_URI="git://git.ghostscript.com/mupdf.git"
+#EGIT_HAS_SUBMODULES=1
+
+LICENSE="AGPL-3"
+MY_SOVER=1.7
+SLOT="0/${MY_SOVER}"
+KEYWORDS=""
+IUSE="X vanilla curl openssl static static-libs"
+
+LIB_DEPEND="dev-libs/openssl[static-libs?]
+ media-libs/freetype:2[static-libs?]
+ media-libs/jbig2dec[static-libs?]
+ media-libs/openjpeg:2[static-libs?]
+ net-misc/curl[static-libs?]
+ virtual/jpeg[static-libs?]
+ X? ( x11-libs/libX11[static-libs?]
+ x11-libs/libXext[static-libs?] )"
+RDEPEND="${LIB_DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ static-libs? ( ${LIB_DEPEND} )
+ static? ( ${LIB_DEPEND//?}
+ app-arch/bzip2[static-libs]
+ x11-libs/libXau[static-libs]
+ x11-libs/libXdmcp[static-libs]
+ x11-libs/libxcb[static-libs] )"
+
+src_prepare() {
+ rm -rf thirdparty || die
+
+ epatch \
+ "${FILESDIR}"/${PN}-1.3-CFLAGS.patch \
+ "${FILESDIR}"/${PN}-1.5-old-debian-files.patch \
+ "${FILESDIR}"/${PN}-1.3-pkg-config.patch \
+ "${FILESDIR}"/${PN}-1.5-Makerules-openssl-curl.patch
+
+ if has_version ">=media-libs/openjpeg-2.1:2" ; then
+ epatch \
+ "${FILESDIR}"/${PN}-1.5-openjpeg-2.1.patch
+ fi
+
+ sed -e "/^libdir=/s:/lib:/$(get_libdir):" \
+ -e "/^prefix=/s:=.*:=${EROOT}/usr:" \
+ -i platform/debian/${PN}.pc || die
+
+ use vanilla || epatch \
+ "${FILESDIR}"/${PN}-1.3-zoom-2.patch
+
+ #http://bugs.ghostscript.com/show_bug.cgi?id=693467
+ sed -e '/^\(Actions\|MimeType\)=/s:\(.*\):\1;:' \
+ -i platform/debian/${PN}.desktop || die
+
+ sed -e "1iOS = Linux" \
+ -e "1iCC = $(tc-getCC)" \
+ -e "1iLD = $(tc-getCC)" \
+ -e "1iAR = $(tc-getAR)" \
+ -e "1iverbose = yes" \
+ -e "1ibuild = debug" \
+ -e "1iprefix = ${ED}usr" \
+ -e "1ilibdir = ${ED}usr/$(get_libdir)" \
+ -e "1idocdir = ${ED}usr/share/doc/${PF}" \
+ -e "1iHAVE_X11 = $(usex X)" \
+ -e "1iWANT_OPENSSL = $(usex openssl)" \
+ -e "1iWANT_CURL = $(usex curl)" \
+ -i Makerules || die
+
+ if use static-libs || use static ; then
+ cp -a "${S}" "${S}"-static || die
+ #add missing Libs.private for xcb and freetype
+ sed -e 's:\(pkg-config --libs\):\1 --static:' \
+ -e '/^SYS_X11_LIBS = /s:\(.*\):\1 -lpthread:' \
+ -e '/^SYS_FREETYPE_LIBS = /s:\(.*\):\1 -lbz2:' \
+ -i "${S}"-static/Makerules || die
+ fi
+
+ my_soname=libmupdf.so.${MY_SOVER}
+ my_soname_js_none=libmupdf-js-none.so.${MY_SOVER}
+ sed -e "\$a\$(MUPDF_LIB): \$(MUPDF_JS_NONE_LIB)" \
+ -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -Wl,--no-undefined -o \$@ \$^ \$(MUPDF_JS_NONE_LIB) \$(LIBS)" \
+ -e "/^MUPDF_LIB :=/s:=.*:= \$(OUT)/${my_soname}:" \
+ -e "\$a\$(MUPDF_JS_NONE_LIB):" \
+ -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname_js_none} -Wl,--no-undefined -o \$@ \$^ \$(LIBS)" \
+ -e "/install/s: COPYING : :" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake XCFLAGS="-fpic"
+ use static-libs && \
+ emake -C "${S}"-static build/debug/lib${PN}{,-js-none}.a
+ use static && \
+ emake -C "${S}"-static XLIBS="-static"
+}
+
+src_install() {
+ if use X ; then
+ domenu platform/debian/${PN}.desktop
+ doicon platform/debian/${PN}.xpm
+ else
+ rm docs/man/${PN}.1
+ fi
+
+ emake install
+ dosym ${my_soname} /usr/$(get_libdir)/lib${PN}.so
+
+ use static-libs && \
+ dolib.a "${S}"-static/build/debug/lib${PN}{,-js-none}.a
+ if use static ; then
+ dobin "${S}"-static/build/debug/mu{tool,draw}
+ use X && dobin "${S}"-static/build/debug/${PN}-x11
+ fi
+ use X && dosym ${PN}-x11 /usr/bin/${PN}
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins platform/debian/${PN}.pc
+
+ dodoc README docs/*.{txt,c}
+}