summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2018-06-27 10:03:42 +0300
committerVirgil Dupras <vdupras@gentoo.org>2018-07-24 21:31:14 -0400
commit856a6ad1fd3dfe1ab67a2976edc3f5dedd694fa3 (patch)
tree0763519a207c41c419552eba5f5d6814fc60fb3e /app-text/mupdf
parentnet-misc/networkmanager-vpnc: security bump to 1.2.6 (diff)
downloadgentoo-856a6ad1fd3dfe1ab67a2976edc3f5dedd694fa3.tar.gz
gentoo-856a6ad1fd3dfe1ab67a2976edc3f5dedd694fa3.tar.bz2
gentoo-856a6ad1fd3dfe1ab67a2976edc3f5dedd694fa3.zip
app-text/mupdf: version bump to 1.13.0
Bug: https://bugs.gentoo.org/646010 Bug: https://bugs.gentoo.org/651828 Bug: https://bugs.gentoo.org/658618
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/Manifest1
-rw-r--r--app-text/mupdf/files/mupdf-1.13-openssl-curl-x11.patch39
-rw-r--r--app-text/mupdf/mupdf-1.13.0.ebuild166
3 files changed, 206 insertions, 0 deletions
diff --git a/app-text/mupdf/Manifest b/app-text/mupdf/Manifest
index 1367f972efcb..a37226db36af 100644
--- a/app-text/mupdf/Manifest
+++ b/app-text/mupdf/Manifest
@@ -1,2 +1,3 @@
DIST mupdf-1.11-source.tar.gz 40156070 BLAKE2B 2a9991a11355a449b91955bd897b5da175d3a89943277345779ea52c74f57c58226ee4087b23e3f434c0a45ae7a39df95c81c26c55d959f362bd1a0d0216716d SHA512 501670f540e298a8126806ebbd9db8b29866f663b7bbf26c9ade1933e42f0c00ad410b9d93f3ddbfb3e45c38722869095de28d832fe3fb3703c55cc9a01dbf63
DIST mupdf-1.12.0-source.tar.gz 51508917 BLAKE2B c34df17f0df7a200897d678514ff4012e02b1cef71189fe48740948c88cb544c6ce80f52a5dc335d70002806a7b413e5f79a1edee88865e42daf76e49416d9bf SHA512 11ae620e55e9ebd5844abd7decacc0dafc90dd1f4907ba6ed12f5c725d3920187fc730a7fc33979bf3ff9451da7dbb51f34480a878083e2064f3455555f47d96
+DIST mupdf-1.13.0-source.tar.gz 51425034 BLAKE2B 7f4a1c84b5840991cc7879f3617165579f4db1f7a010a8313b0eaf94ad59af60bb3d0e4a0f2acc14d2c7511dd0f8b96c89c51e360ab379ba32590b887dd3be6a SHA512 d7fca7292e612959893a728d35964cf7b4e607385bdd72e81b8ca1de6ab642f999b734afbbf32d75400cd29b7e178ec360e65c91d7b1e1a53c2a04ff0adbd707
diff --git a/app-text/mupdf/files/mupdf-1.13-openssl-curl-x11.patch b/app-text/mupdf/files/mupdf-1.13-openssl-curl-x11.patch
new file mode 100644
index 000000000000..6db51a083edb
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.13-openssl-curl-x11.patch
@@ -0,0 +1,39 @@
+diff --git a/Makerules b/Makerules
+index ef2b6b0..f9b25d6 100644
+--- a/Makerules
++++ b/Makerules
+@@ -104,12 +104,17 @@ HAVE_GLUT := yes
+ SYS_GLUT_CFLAGS :=
+ SYS_GLUT_LIBS := -lglut -lGL
+
++WANT_OPENSSL ?= yes
++ifeq "$(WANT_OPENSSL)" "yes"
+ ifeq "$(shell pkg-config --exists 'libcrypto >= 1.1.0' && echo yes)" "yes"
+ HAVE_LIBCRYPTO := yes
+ SYS_LIBCRYPTO_CFLAGS := -DHAVE_LIBCRYPTO $(shell pkg-config --cflags libcrypto)
+ SYS_LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
+ endif
++endif
+
++WANT_CURL ?= yes
++ifeq "$(WANT_CURL)" "yes"
+ ifeq "$(shell pkg-config --exists libcurl && echo yes)" "yes"
+ HAVE_CURL := yes
+ SYS_CURL_CFLAGS := $(shell pkg-config --cflags libcurl)
+@@ -121,12 +126,16 @@ SYS_CURL_DEPS += $(shell pkg-config --libs openssl)
+ endif
+ endif
+ SYS_CURL_DEPS += -lpthread -lrt
++endif
+
++WANT_X11 ?= yes
++ifeq "$(WANT_X11)" "yes"
+ ifeq "$(shell pkg-config --exists x11 xext && echo yes)" "yes"
+ HAVE_X11 := yes
+ SYS_X11_CFLAGS := $(shell pkg-config --cflags x11 xext)
+ SYS_X11_LIBS := $(shell pkg-config --libs x11 xext)
+ endif
++endif
+
+ ifeq "$(shell pkg-config --exists harfbuzz && echo yes)" "yes"
+ SYS_HARFBUZZ_CFLAGS := $(shell pkg-config --cflags harfbuzz)
diff --git a/app-text/mupdf/mupdf-1.13.0.ebuild b/app-text/mupdf/mupdf-1.13.0.ebuild
new file mode 100644
index 000000000000..413d97b408e7
--- /dev/null
+++ b/app-text/mupdf/mupdf-1.13.0.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="https://mupdf.com/"
+SRC_URI="https://mupdf.com/downloads/${P}-source.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="X +curl javascript lcms libressl opengl +openssl static static-libs vanilla"
+
+LIB_DEPEND="
+ !libressl? ( dev-libs/openssl:0=[static-libs?] )
+ libressl? ( dev-libs/libressl:0=[static-libs?] )
+ javascript? ( >=dev-lang/mujs-0_p20160504 )
+ media-libs/freetype:2=[static-libs?]
+ media-libs/harfbuzz:=[static-libs?]
+ media-libs/jbig2dec:=[static-libs?]
+ media-libs/libpng:0=[static-libs?]
+ >=media-libs/openjpeg-2.1:2=[static-libs?]
+ net-misc/curl[static-libs?]
+ virtual/jpeg[static-libs?]
+ X? ( x11-libs/libX11[static-libs?]
+ x11-libs/libXext[static-libs?] )
+ opengl? ( >=media-libs/freeglut-3.0.0:= )"
+RDEPEND="${LIB_DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ static-libs? ( ${LIB_DEPEND} )
+ static? ( ${LIB_DEPEND//?}
+ app-arch/bzip2[static-libs]
+ x11-libs/libXau[static-libs]
+ x11-libs/libXdmcp[static-libs]
+ x11-libs/libxcb[static-libs] )"
+
+REQUIRED_USE="opengl? ( !static !static-libs )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12-CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.9a-debug-build.patch
+ "${FILESDIR}"/${PN}-1.10a-add-desktop-pc-xpm-files.patch
+ "${FILESDIR}"/${PN}-1.13-openssl-curl-x11.patch
+ "${FILESDIR}"/${PN}-1.11-drop-libmupdfthird.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ use hppa && append-cflags -ffunction-sections
+
+ # specialized lcms2, keep it if wanted inside lubmupdfthird
+ if ! use lcms ; then
+ rm -rf thirdparty/lcms2
+ fi
+
+ rm -rf thirdparty/{README,curl,freeglut,freetype,harfbuzz,jbig2dec,libjpeg,mujs,openjpeg,zlib} || die
+ for my_third in thirdparty/* ; do
+ ewarn "Bundled thirdparty lib: ${my_third}"
+ done
+
+ if has_version ">=media-libs/openjpeg-2.1:2" ; then
+ # Remove a switch, which prevents using shared libraries for openjpeg2.
+ # See http://www.linuxfromscratch.org/blfs/view/cvs/pst/mupdf.html
+ sed '/OPJ_STATIC$/d' -i source/fitz/load-jpx.c
+ fi
+
+ use javascript || \
+ sed -e '/* #define FZ_ENABLE_JS/ a\#define FZ_ENABLE_JS 0' \
+ -i include/mupdf/fitz/config.h
+
+ sed -e "/^libdir=/s:/lib:/$(get_libdir):" \
+ -e "/^prefix=/s:=.*:=${EROOT}/usr:" \
+ -i platform/debian/${PN}.pc || die
+
+ use vanilla || eapply \
+ "${FILESDIR}"/${PN}-1.3-zoom-2.patch
+
+ sed -e "1iOS = Linux" \
+ -e "1iCC = $(tc-getCC)" \
+ -e "1iLD = $(tc-getCC)" \
+ -e "1iAR = $(tc-getAR)" \
+ -e "1iverbose = yes" \
+ -e "1ibuild = debug" \
+ -e "1iprefix = ${ED}usr" \
+ -e "1ilibdir = ${ED}usr/$(get_libdir)" \
+ -e "1idocdir = ${ED}usr/share/doc/${PF}" \
+ -i Makerules || die
+
+ if use static-libs || use static ; then
+ cp -a "${S}" "${S}"-static || die
+ #add missing Libs.private for xcb and freetype
+ sed -e 's:\(pkg-config --libs\):\1 --static:' \
+ -e '/^SYS_X11_LIBS = /s:\(.*\):\1 -lpthread:' \
+ -e '/^SYS_FREETYPE_LIBS = /s:\(.*\):\1 -lbz2:' \
+ -i "${S}"-static/Makerules || die
+ fi
+
+ my_soname=libmupdf.so.${PV}
+ my_soname_js_none=libmupdf-js-none.so.${PV}
+ sed -e "\$a\$(MUPDF_LIB): \$(MUPDF_JS_NONE_LIB)" \
+ -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname} -Wl,--no-undefined -o \$@ \$^ \$(MUPDF_JS_NONE_LIB) \$(LIBS)" \
+ -e "/^MUPDF_LIB =/s:=.*:= \$(OUT)/${my_soname}:" \
+ -e "\$a\$(MUPDF_JS_NONE_LIB):" \
+ -e "\$a\\\t\$(QUIET_LINK) \$(CC) \$(LDFLAGS) --shared -Wl,-soname -Wl,${my_soname_js_none} -Wl,--no-undefined -o \$@ \$^ \$(LIBS)" \
+ -e "/install/s: COPYING : :" \
+ -i Makefile || die
+}
+
+src_compile() {
+ use lcms && emake XCFLAGS="-fpic" third
+ emake XCFLAGS="-fpic" \
+ HAVE_GLUT=$(usex opengl yes no) \
+ HAVE_MUJS=$(usex javascript) \
+ MUJS_LIBS=$(usex javascript -lmujs '') \
+ WANT_CURL=$(usex curl) \
+ WANT_OPENSSL=$(usex openssl) \
+ WANT_X11=$(usex X)
+
+ use static-libs && \
+ emake -C "${S}"-static build/debug/lib${PN}{,-js-none}.a
+ use static && \
+ emake -C "${S}"-static XLIBS="-static"
+}
+
+src_install() {
+ if use X || use opengl ; then
+ domenu platform/debian/${PN}.desktop
+ doicon platform/debian/${PN}.xpm
+ else
+ rm docs/man/${PN}.1
+ fi
+
+ emake install \
+ HAVE_GLUT=$(usex opengl yes no) \
+ HAVE_MUJS=$(usex javascript) \
+ MUJS_LIBS=$(usex javascript -lmujs '') \
+ WANT_CURL=$(usex curl) \
+ WANT_OPENSSL=$(usex openssl) \
+ WANT_X11=$(usex X)
+
+ dosym ${my_soname} /usr/$(get_libdir)/lib${PN}.so
+
+ use static-libs && \
+ dolib.a "${S}"-static/build/debug/lib${PN}{,-js-none}.a
+ if use static ; then
+ dobin "${S}"-static/build/debug/mu{tool,draw}
+ use X && dobin "${S}"-static/build/debug/${PN}-x11
+ fi
+ if use opengl ; then
+ einfo "mupdf symlink points to mupdf-gl (bug 616654)"
+ dosym ${PN}-gl /usr/bin/${PN}
+ elif use X ; then
+ einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
+ dosym ${PN}-x11 /usr/bin/${PN}
+ fi
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins platform/debian/${PN}.pc
+
+ dodoc README CHANGES CONTRIBUTORS
+}