summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2018-01-08 20:31:00 +0100
committerCraig Andrews <candrews@gentoo.org>2018-01-08 15:10:25 -0500
commit834fadaabc9fdc0d09a8c2380d536b62ad08a0ca (patch)
tree2e616d9582ec5e216ef800c329b2102d1f5144ce /app-text/nfoview
parentapp-text/nfoview: add proxy maintainer (diff)
downloadgentoo-834fadaabc9fdc0d09a8c2380d536b62ad08a0ca.tar.gz
gentoo-834fadaabc9fdc0d09a8c2380d536b62ad08a0ca.tar.bz2
gentoo-834fadaabc9fdc0d09a8c2380d536b62ad08a0ca.zip
app-text/nfoview: version bump to 1.23
Closes: https://bugs.gentoo.org/643902 Closes: https://bugs.gentoo.org/614314 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/Manifest1
-rw-r--r--app-text/nfoview/nfoview-1.23.ebuild41
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild6
3 files changed, 45 insertions, 3 deletions
diff --git a/app-text/nfoview/Manifest b/app-text/nfoview/Manifest
index e7249561d0a1..b11d2108ccfa 100644
--- a/app-text/nfoview/Manifest
+++ b/app-text/nfoview/Manifest
@@ -1 +1,2 @@
+DIST 1.23.tar.gz 83337 BLAKE2B d73cd6987bf7929c57e8acf0a24278272ea199bf980756ddb5da9a5eddf7760a8c05f0e48a287ee760d4bf4d2594fb08b43a77cef46d371a746629bf76955e91 SHA512 b94724e130cdf58b911634496c52361d008ebfafab3ac40a76612c4891737d4145596a6badc15fe4228c90c1cd7261e5a892e3e462070ebb55f71332b36345d7
DIST nfoview-1.15.1.tar.xz 88400 BLAKE2B 4e0f2d6df179a25f7fbf9b762dab70f1331d31fc1fed018e71101171d6bbcce9b67f9c4f4a3c35fbf22ed3123e90934b035290d3fae5a4d396ddc6fdc04ce133 SHA512 e4cf86003b03ae57b8a4e76990df77c7e9e441abd8ab0440385405b0f600a85539a152de5893ebe75797bd96ecb811086c48b1439b9f8719050eb12315f67426
diff --git a/app-text/nfoview/nfoview-1.23.ebuild b/app-text/nfoview/nfoview-1.23.ebuild
new file mode 100644
index 000000000000..860d9eb9b041
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.23.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
index f8030006af37..860d9eb9b041 100644
--- a/app-text/nfoview/nfoview-9999.ebuild
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,12 +11,12 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
inherit git-r3
else
- SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
-HOMEPAGE="http://home.gna.org/nfoview/"
+HOMEPAGE="https://otsaloma.io/nfoview/"
LICENSE="GPL-3"
SLOT="0"