summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2020-12-14 15:41:52 +0100
committerSam James <sam@gentoo.org>2020-12-16 08:14:57 +0000
commitb05be2fa06fa2b7fc7b103bb1ee1d7cee7164013 (patch)
tree98a2c4bbdda1e6f04ffb649246a94a8bc7c136dd /app-text/nfoview
parentapp-text/nfoview: add python3_9 compatibility (diff)
downloadgentoo-b05be2fa06fa2b7fc7b103bb1ee1d7cee7164013.tar.gz
gentoo-b05be2fa06fa2b7fc7b103bb1ee1d7cee7164013.tar.bz2
gentoo-b05be2fa06fa2b7fc7b103bb1ee1d7cee7164013.zip
app-text/nfoview: update live to latest changes
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Closes: https://github.com/gentoo/gentoo/pull/18650 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
index a6e9e5a10d68..d8afed881837 100644
--- a/app-text/nfoview/nfoview-9999.ebuild
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit distutils-r1 gnome2-utils xdg-utils
+inherit distutils-r1 xdg-utils
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
@@ -22,16 +23,18 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE=""
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext"
DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
- media-fonts/terminus-font"
+ media-fonts/cascadia-code"
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}