summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-01-12 20:57:45 +0100
committerFabian Groffen <grobian@gentoo.org>2017-01-12 20:57:45 +0100
commitc4068766f069ccc354ad7b796e9e3f894a6d3dd6 (patch)
tree63205a960fc55eb2715301b124f4244205d00eb0 /app-text/openjade/openjade-1.3.2-r6.ebuild
parentdev-go/golint: new package (diff)
downloadgentoo-c4068766f069ccc354ad7b796e9e3f894a6d3dd6.tar.gz
gentoo-c4068766f069ccc354ad7b796e9e3f894a6d3dd6.tar.bz2
gentoo-c4068766f069ccc354ad7b796e9e3f894a6d3dd6.zip
app-text/openjade: fix compilation using Clang, bug #604534
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/openjade/openjade-1.3.2-r6.ebuild')
-rw-r--r--app-text/openjade/openjade-1.3.2-r6.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-text/openjade/openjade-1.3.2-r6.ebuild b/app-text/openjade/openjade-1.3.2-r6.ebuild
index 0bb418f7b93d..2e968d49858e 100644
--- a/app-text/openjade/openjade-1.3.2-r6.ebuild
+++ b/app-text/openjade/openjade-1.3.2-r6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit autotools sgml-catalog eutils flag-o-matic multilib
+inherit autotools sgml-catalog eutils flag-o-matic multilib toolchain-funcs
DESCRIPTION="Jade is an implementation of DSSSL for formatting SGML and XML documents"
HOMEPAGE="http://openjade.sourceforge.net"
@@ -53,7 +53,7 @@ src_configure() {
# avoids dead-store elimination optimization
# leading to segfaults on GCC 6
# bug #592590 #596506
- append-cxxflags $(test-flags-CXX -fno-lifetime-dse)
+ tc-is-clang || append-cxxflags $(test-flags-CXX -fno-lifetime-dse)
# We need Prefix env, bug #287358
export CONFIG_SHELL="${CONFIG_SHELL:-${BASH}}"