summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-03-28 14:16:09 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-03-28 14:20:35 +0200
commit9ca1a82173d2d881a06652f7eaa6611ff038a973 (patch)
tree1fcbc79c6cd8f6aa7acb620cdc5423d90b14e90d /app-text/paperwork-backend/paperwork-backend-1.1.2.ebuild
parentmedia-sound/pulseaudio: remove old (diff)
downloadgentoo-9ca1a82173d2d881a06652f7eaa6611ff038a973.tar.gz
gentoo-9ca1a82173d2d881a06652f7eaa6611ff038a973.tar.bz2
gentoo-9ca1a82173d2d881a06652f7eaa6611ff038a973.zip
app-text/paperwork-backend: 1.1.2 bump, bug #613572
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text/paperwork-backend/paperwork-backend-1.1.2.ebuild')
-rw-r--r--app-text/paperwork-backend/paperwork-backend-1.1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/paperwork-backend/paperwork-backend-1.1.2.ebuild b/app-text/paperwork-backend/paperwork-backend-1.1.2.ebuild
new file mode 100644
index 000000000000..e287a22cac97
--- /dev/null
+++ b/app-text/paperwork-backend/paperwork-backend-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend part of Paperwork (Python API, no UI)"
+HOMEPAGE="https://github.com/jflesch/paperwork-backend"
+SRC_URI="https://github.com/jflesch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/poppler[introspection]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"