summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pdf2html
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pdf2html')
-rw-r--r--app-text/pdf2html/Manifest1
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-gentoo.patch54
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-libpng15.patch10
-rw-r--r--app-text/pdf2html/metadata.xml5
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild48
5 files changed, 118 insertions, 0 deletions
diff --git a/app-text/pdf2html/Manifest b/app-text/pdf2html/Manifest
new file mode 100644
index 000000000000..dd02d94b84b0
--- /dev/null
+++ b/app-text/pdf2html/Manifest
@@ -0,0 +1 @@
+DIST pdf2html-1.4.tgz 22976 SHA256 71ee70c56ec1629442518992e1de743287d7b8799d0aae75e3be8095f7245b61 SHA512 00488c5e6303e1609294e7873c892866d19f3ee820f22f2d75436de22037bf3e4e1a565b7db29df5f6b20a76c5e2df4786e39e1d803cd7cca88274da65c7bbbb WHIRLPOOL b2b85e7bf705fcb1cbeca36d66593342725bcc6cccf699ae443b0150f757ed54ead385c7f7e84302a51d3cc995a3ee066980447d6948518f685edf7236df7d87
diff --git a/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch b/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
new file mode 100644
index 000000000000..715b829b1c2a
--- /dev/null
+++ b/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
@@ -0,0 +1,54 @@
+--- pbm2png.c.orig 2003-09-16 20:12:55.000000000 +0900
++++ pbm2png.c 2004-02-21 22:09:57.415786664 +0900
+@@ -145,15 +145,13 @@
+ sprintf(string,"%s%d.html",basename,index);
+ f=fopen(string,"w");
+
+- fprintf(f,"<html><head><title>%s</title></head><body bgcolor=\"#000000\" text=\"#00ff00\" link=\"#ffff00\" vlink=\"#00ffff\"
+-alink=\"#ffff00\">\n",titlestring);
++ fprintf(f,"<html><head><title>%s</title></head><body bgcolor=\"#000000\" text=\"#00ff00\" link=\"#ffff00\" vlink=\"#00ffff\" alink=\"#ffff00\">\n",titlestring);
+ fprintf(f,"<h1>%s, Page %d</h1>\n",titlestring,index+pageoffset);
+ fprintf(f,"<p><table border=0 cellspacing=0 cellpadding=2><tr>");
+ fprintf(f,"<td valign=\"top\"><table border=0 cellpadding=0 cellspacing=0><tr><td>");
+ if (index)
+ {
+- fprintf(f,"<a href=\"%s%d.html\"><img src=\"left.png\" border=0
+-></a>\n",basename,index-1);
++ fprintf(f,"<a href=\"%s%d.html\"><img src=\"left.png\" border=0></a>\n",basename,index-1);
+ }
+ else
+ {
+@@ -162,18 +160,15 @@
+ fprintf(f,"</td><td>");
+ if (index<filenumber-1)
+ {
+- fprintf(f,"<a href=\"%s%d.html\">
+-<img src=\"right.png\" border=0></a>\n",basename,index+1);
++ fprintf(f,"<a href=\"%s%d.html\"> <img src=\"right.png\" border=0></a>\n",basename,index+1);
+ }
+ else
+ {
+ fprintf(f,"<img src=\"right.png\" border=0>\n");
+ }
+- fprintf(f,"</td></tr><tr><td colspan=2><a href=\"index.html\">
+-<img src=\"idx.png\" border=0 ></a></td>");
++ fprintf(f,"</td></tr><tr><td colspan=2><a href=\"index.html\"><img src=\"idx.png\" border=0 ></a></td>");
+ fprintf(f,"</tr></table>");
+- fprintf(f,"</td><td><img src=\"%s%d.png\" border=\"0\"
+-></td>\n</tr></table>",basename,index);
++ fprintf(f,"</td><td><img src=\"%s%d.png\" border=\"0\"></td>\n</tr></table>",basename,index);
+ fprintf(f,"</body></html>");
+ fclose(f);
+ }
+@@ -438,9 +433,8 @@
+ int a,z;
+
+ if (argc<7){
+- fprintf(stderr,"Usage: pbm2png <dpi> <basename> <titlestring>
+-<bottom_html_code> <pageoffset> <ifname> [starting_filenumber [invert]]\n");
+- return 0;
++ fprintf(stderr,"Usage: pbm2png <dpi> <basename> <titlestring> <bottom_html_code> <pageoffset> <ifname> [starting_filenumber [invert]]\n");
++ return 0;
+ }
+ dpi=atol(argv[1]);
+ ppm=dpi*1000/25.4;
diff --git a/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
new file mode 100644
index 000000000000..72a0e1b65af9
--- /dev/null
+++ b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
@@ -0,0 +1,10 @@
+--- pbm2png.c
++++ pbm2png.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <zlib.h> /* Z_BEST_COMPRESSION */
+ #include <png.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/app-text/pdf2html/metadata.xml b/app-text/pdf2html/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/pdf2html/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
new file mode 100644
index 000000000000..33dbc37bf12a
--- /dev/null
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts pdf files to html files"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/pdf2html/"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/clock/pdf2html/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=">=media-libs/libpng-1.4
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl
+ >=media-gfx/imagemagick-6"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_compile() {
+ tc-export CC
+ # Rewrite the Makefile as that's simpler
+ echo "LDLIBS=-lpng" > Makefile
+ echo "all: pbm2png" >> Makefile
+ emake
+ echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile
+ emake pbm2eps9
+
+ echo "cp \"${EPREFIX}\"/usr/share/${P}/*.png ." >> pdf2html
+}
+
+src_install() {
+ dobin pbm2png pbm2eps9 pdf2html ps2eps9
+
+ insinto /usr/share/${P}
+ doins *.png *.html
+
+ dodoc CHANGELOG README VERSION
+}