summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-30 22:57:15 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-30 22:57:31 +0100
commit501d60fe95831fe5b55ab586fddbc966d5a39127 (patch)
tree877fec87c7da5ee4fd54d9d2f9287dfa87628831 /app-text/pdf2htmlEX
parentgames-emulation/vbam: add missing setup-wxwidgets() (diff)
downloadgentoo-501d60fe95831fe5b55ab586fddbc966d5a39127.tar.gz
gentoo-501d60fe95831fe5b55ab586fddbc966d5a39127.tar.bz2
gentoo-501d60fe95831fe5b55ab586fddbc966d5a39127.zip
app-text/pdf2htmlEX: Enforce building without PIE, bug 642210
To do this cleanly we require at least gcc-6 (otherwise the ebuild becomes one big mess). Closes: https://bugs.gentoo.org/642210 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/pdf2htmlEX')
-rw-r--r--app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild b/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild
index d02dd44ec396..5b00b84e7746 100644
--- a/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild
+++ b/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils toolchain-funcs flag-o-matic
DESCRIPTION="A precise PDF to HTML converter"
HOMEPAGE="http://coolwanglu.github.io/pdf2htmlEX/"
@@ -14,7 +14,7 @@ SRC_URI="
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
IUSE=""
@@ -30,3 +30,19 @@ RDEPEND="${CDEPEND}
DEPEND="${CDEPEND}
virtual/pkgconfig
"
+
+pkg_pretend() {
+ local ver=6.4.0
+ local msg="${P} needs at least GCC ${ver} set to compile."
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! version_is_at_least ${ver} $(gcc-fullversion); then
+ die ${msg}
+ fi
+ fi
+}
+
+src_configure() {
+ append-cflags -no-pie
+ append-cxxflags -no-pie
+ cmake-utils_src_configure
+}