summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-02-13 17:39:23 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-02-13 17:40:07 +0700
commit307c5e8145980039398bcad09ea9f7080dd6513f (patch)
treef8428035adea9ec6171e9f4c69d9fb73000933eb /app-text/pdfarranger
parentapp-editors/emacs: Remove old (diff)
downloadgentoo-307c5e8145980039398bcad09ea9f7080dd6513f.tar.gz
gentoo-307c5e8145980039398bcad09ea9f7080dd6513f.tar.bz2
gentoo-307c5e8145980039398bcad09ea9f7080dd6513f.zip
app-text/pdfarranger: bump to 1.7.0
Closes: https://bugs.gentoo.org/770211 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/pdfarranger')
-rw-r--r--app-text/pdfarranger/Manifest1
-rw-r--r--app-text/pdfarranger/pdfarranger-1.7.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 0ac249cc8ead..2e5a8c74453c 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1,3 +1,4 @@
DIST pdfarranger-1.3.1.tar.gz 120834 BLAKE2B 5f429d479d130ec06e795c6cedc2aefa75f89b971b556901fc0bfba02038e36c4fd7b4233b5ce6d0dfb6252862176dc7b07192ab43e458090970a25648bb946e SHA512 6ac13447410477e9125da26adbf7123f7f5ffa25814a4c254247a5ff2d07eba6af0557eafb60b4c68ac5987c8e9e7888da21296fb6a74d31a3d0d763b1077918
DIST pdfarranger-1.5.3.tar.gz 221208 BLAKE2B 2669a3be00d771542ba2449696de74d633fe31c1ab84ff368ea95ffd6e6f6bdd4d5bbb2b0b2cf1c2ddcddcba9e774f1870ee3c85735f54c832894e2093392042 SHA512 17960786b2197e4035b2c224cbeb8e6d14ca7690920a4366d3dcad8b19f890b52d5e95277372fe3011f3476a5be0c4f253eb4d3ee3b6a8df74e20468be124d8b
DIST pdfarranger-1.6.2.tar.gz 197726 BLAKE2B aee8ee7d32603f20bc01d9f5f77290390e8a038bf79e3c4f689a71ec1c3e454784b2225b43d33bdfd7897785827141cfe1770dcf41d233c4ec1f3865d6f1e3c0 SHA512 610c4dfaa141cfb8caebfc72b524cda05455ed4a5c1e336772655bd02ceac25fafedb439dbe83e87c88da189147eaf91149e9af92ec745a52f8a24fcee5fd390
+DIST pdfarranger-1.7.0.tar.gz 236125 BLAKE2B f16eb23fb597a22a48f075ee6435c74d51a4c45d35e03ec02b2b2353c29ad327f36f6af9ef028ddc53777ecae069e62437728308cda2a6296bd520c2a54e1220 SHA512 8f3c804119d5e4aa78cdae1964757be3404977a68dacccddea0e3e598c531a0ae163567709358ccd60764bebf3a55b5ed1bfbd2e0392c97569ffd9a18f549552
diff --git a/app-text/pdfarranger/pdfarranger-1.7.0.ebuild b/app-text/pdfarranger/pdfarranger-1.7.0.ebuild
new file mode 100644
index 000000000000..f3d0a8fa4fe9
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature xdg-utils desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages."
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ elog "Optional dependency:"
+ optfeature "image file import" media-gfx/img2pdf
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}