summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:50 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:43:44 +0100
commit55ffd36c532cb97cecd4949617907b1dc759bf62 (patch)
treec7ce75069acd984332fe18430480a4bf2f6dd84c /app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild
parentapp-text/pdf2oo: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-55ffd36c532cb97cecd4949617907b1dc759bf62.tar.gz
gentoo-55ffd36c532cb97cecd4949617907b1dc759bf62.tar.bz2
gentoo-55ffd36c532cb97cecd4949617907b1dc759bf62.zip
app-text/pdfsandwich: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild')
-rw-r--r--app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild b/app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..f02dc56f52d5
--- /dev/null
+++ b/app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="generator of sandwich OCR pdf files"
+HOMEPAGE="http://www.tobias-elze.de/pdfsandwich"
+SRC_URI="mirror://sourceforge/pdfsandwich/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="png"
+
+RDEPEND=">=app-text/tesseract-3.00
+ media-gfx/exact-image
+ app-text/unpaper
+ app-text/ghostscript-gpl
+ virtual/imagemagick-tools[png?]"
+DEPEND="sys-apps/gawk
+ >=dev-lang/ocaml-3.10[ocamlopt]"
+
+src_prepare() {
+ sed -i "/^OCAMLOPTFLAGS/s/$/ -ccopt \"\$(CFLAGS) \$(LDFLAGS)\"/" Makefile || die
+ sed -i "s/install -s/install/" Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ elog "pdfsandwich relies on the tesseract library for OCR."
+ elog "Consequently language support is determined by tesseract's"
+ elog "language support which in turn is controlled via the LINGUAS"
+ elog "variable in make.conf."
+}