summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-09-05 12:00:27 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-09-05 13:50:33 +0200
commitcdbdd31fe0cd528853445b2dbccc1d6b4215eeec (patch)
treed7095846da0c0a450fcb8f7f1e529f9302698768 /app-text/pdftk/pdftk-3.0.0.ebuild
parentx11-drivers/nvidia-drivers: Old. (diff)
downloadgentoo-cdbdd31fe0cd528853445b2dbccc1d6b4215eeec.tar.gz
gentoo-cdbdd31fe0cd528853445b2dbccc1d6b4215eeec.tar.bz2
gentoo-cdbdd31fe0cd528853445b2dbccc1d6b4215eeec.zip
app-text/pdftk: Make ebuild a bit more flexible; add release ebuild
Diffstat (limited to 'app-text/pdftk/pdftk-3.0.0.ebuild')
-rw-r--r--app-text/pdftk/pdftk-3.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/pdftk/pdftk-3.0.0.ebuild b/app-text/pdftk/pdftk-3.0.0.ebuild
new file mode 100644
index 000000000000..c07263f6856d
--- /dev/null
+++ b/app-text/pdftk/pdftk-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="gcj-free version of pdftk written in Java"
+HOMEPAGE="https://gitlab.com/pdftk-java/pdftk"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/pdftk-java/pdftk/"
+else
+ SRC_URI="https://gitlab.com/pdftk-java/pdftk/-/archive/v${PV}/pdftk-v${PV}.tar.bz2"
+ KEYWORDS=""
+ S="${WORKDIR}/pdftk-v${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+JAVA_PKG_STRICT="yes"
+EANT_GENTOO_CLASSPATH="bcprov,commons-lang-3.6"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+CDEPEND="
+ dev-java/bcprov:0
+ dev-java/commons-lang:3.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.7"
+
+src_install() {
+ java-pkg_newjar "build/jar/pdftk.jar"
+ java-pkg_dolauncher
+}