summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-09-20 10:43:43 +0200
committerDirkjan Ochtman <djc@gentoo.org>2015-09-20 10:43:43 +0200
commit5b93b4517499ae57cb3ad30b69f6e73481a08af6 (patch)
tree6432ad530dd32574773f39d5ac3a30311f09ea45 /app-text/pelican/pelican-3.6.3.ebuild
parentdev-python/ipython: Stable for PPC64 (bug #560708). (diff)
downloadgentoo-5b93b4517499ae57cb3ad30b69f6e73481a08af6.tar.gz
gentoo-5b93b4517499ae57cb3ad30b69f6e73481a08af6.tar.bz2
gentoo-5b93b4517499ae57cb3ad30b69f6e73481a08af6.zip
app-text/pelican: version bump to 3.6.3
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-text/pelican/pelican-3.6.3.ebuild')
-rw-r--r--app-text/pelican/pelican-3.6.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pelican/pelican-3.6.3.ebuild b/app-text/pelican/pelican-3.6.3.ebuild
new file mode 100644
index 000000000000..a16143d1e200
--- /dev/null
+++ b/app-text/pelican/pelican-3.6.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files"
+HOMEPAGE="http://pelican.notmyidea.org/ https://pypi.python.org/pypi/pelican"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( README.rst )
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)
+
+#python_test() {
+# esetup.py test
+#}